Unable to use relay output on pixhawk or RPi

Hi @EliotBR ,

Hope you are well.

A client of mine is asking how to control our LASER via the pixhawk and I thought I’d give it a try.

To turn the laser off, the control wire must be set to 0V, to turn it on, anything other than 0V.

I was thinking the relay output would be the key but I guess I am not understanding how this work.

I have the LASER signal pin only connected to PWM sig on AUX1 on the Pixhawk.

I have a button assign to button input 9 and assigned that to Relay 1 Toggle (on/off). I then configured relay 1 to be on AUX1.

I would expect either 0 or 3.3V to appear on AUX 1 signal but got nothing.

What am I doing wrong?

FYI I also tried to map it to GPIO pins 5 or 6 and still no results.

I guess I am missing something.


Hi @etienne,

I’m off to sleep now, but this comment may be relevant - I expect it’s likely an issue with the pin(s) being incorrectly configured as GPIO or PWM.

If that doesn’t help, please specify which ArduSub version you’re testing with and I’ll try to verify the behaviour later in the week.

Thanks for the quick response.

I will have a look in the morning.

I am running the latest stable version and BLUOS.


Did this end up getting resolved?

I’ve just tried with both ArduSub 4.1.0 (latest stable) and 4.0.3 (previous stable), and leaving the AUXOUT5 as the default RELAY_PIN works fine for me with the relay_1 joystick functions.

I then tried to get AUX 1 working as a relay, which worked once I set BRD_PWM_COUNT to No PWMs (since they start counting from AUX 1) :slight_smile:

Hi Eliot,

I tried setting Servo9 to disabled and it didn’t do anything. On the Scope it was still a PWM.

I also tried GPIO6 and nothing happened. The output was always high.

I will give this another go.


Hi Eliot,

We tried it and got the same results as you.

Unfortunately setting BRD_PWM_COUNT to No PWMs means AUX2 can’t be used for tilt and AUX3 can’t be used for Manip.

So we just connected it on AUX5.

Many thanks for your help.


1 Like