Unable to switch to guided mode

BlueROV2(RaspberryPi4B + NAVIGATOR)(No GPS)

I want manual control, but I can’t switch to Guided mode.
Added port:27000 with NMEA Injector.
Sending dummy data(GPGGA) to the 27000 did not go into Guided mode.
After checking, the values of GPS_INPUT(Component ID:220) lat and lon are changing.
What else should i do?

There was an article that GPS feedback is required to shift to Guided mode.
What is GPS Feedback?

In the past, ArduSub was a bit picky about the GGA messages, so make sure you are sending all of the needed values, like hdop and particularly the number of satellites value which should be something like 15 or more.

Thank you for your reply

hdop is a fixed value : 0.92…
satellites_visible is 16

  "message": {
    "alt": 15.199999809265137,
    "fix_type": 3,
    "gps_id": 0,
    "hdop": 0.9200000166893005,
    "horiz_accuracy": 0.0,
    "ignore_flags": {
      "bits": 56
    "lat": 580165000,
    "lon": -108300833,
    "satellites_visible": 16,
    "speed_accuracy": 0.0,
    "time_usec": 0,
    "time_week": 0,
    "time_week_ms": 0,
    "type": "GPS_INPUT",
    "vd": 0.0,
    "vdop": 0.0,
    "ve": 0.0,
    "vert_accuracy": 0.0,
    "vn": 0.0,
    "yaw": 0
  "status": {
    "time": {
      "counter": 65482,
      "first_update": "2023-06-01T05:11:27.383203883+00:00",
      "frequency": 0.9981859922409058,
      "last_update": "2023-06-01T23:24:48.779909821+00:00"

QGroundControl does not change.
I can’t even switch to guided mode.

Yes, if ArduSub isn’t happy with the position info it is receiving it won’t allow you to switch into guided or position-hold modes. Exactly what info it requires and in what ranges (for example, “vdop is required and must not be greater than 3.0” or some other value) isn’t documented anywhere I can find. Perhaps the BR staff could post here some example GGA messages from a system that is known to work, like the WaterLinked SBL?

We’ll need some info from @williangalvani about the requirements here, because I haven’t looked into this part of the firmware before.

From some initial searching, it seems that

Thank you for your reply

I sent GPGSA, but it was not reflected in GPS_INPUT.
The comments on “” make it sound like it doesn’t support GPGSA, including VDOP.

Even changing the value of EK3_GPS_CHECK from 31 to 0 or 3 did not lead to Guided mode.

Examine AP_NavEKF3_VehicleStatus.cpp.

I’ve checked AP_NavEKF3_VehicleStatus.cpp, but I’m not sure if it uses data received over UDP.

BlueROV2(RaspberryPi4B + NAVIGATOR)(No GPS)
How can I move to Guided mode with this configuration?
BlueROV2 settings and parameters, QGroundControl settings and whether to start, what do you need?
Should I replace NAVIGATOR with Pixhawk?

Can I switch to Guided mode with UnderWaterGPS?

Yes, and I’ve done it with a couple of different USBL systems sending GPGGA messages.