Home        Store        Docs        Blog

Top-right motor (T5) mismapped using joystick


(Genevieve) #1

Our lab recently purchased a BlueROV2 with the RPI companion computer setup. We’ve assembled it, and used both QGroundControl and MAVROS with a F310 joystick to control the ROV over a tether. We had a fairly successful tank test yesterday, but had an issue with the top-right thruster (T5).

Yaw control and forward backward motion worked fine. Roll control also appeared to work (both T5 and T6 operated and the robot was able to roll). However, when we tried up/down control, T5 does not turn on. T6 behaved normally, so the robot was able to ascend/descend very slowly using only the top-left thurster, but T5 does not move. This is all in manual mode.

We tried recalibrating the joystick using QGC and checked the connections to T5. This problem appears when controlling the robot both with QGC and with the MAVROS teleop_joy lauch file. The param file loaded is the one linked here. I updated the firmware on the Px4 ~3 weeks ago. We are using T-200s.

Is there somewhere in the parameters or elsewhere where the motor mapping for T5 could be wrong?
Thanks all!


(Jacob) #2

@geflaspohler,

This is an interesting problem, because the thruster is spinning for roll control. Does the thruster spin in stabilize or depth hold mode when you try to ascend/descend? Joystick calibration should not matter here.

Note that that parameter file was for ArduSub 3.4. If you continue to have issues, I would suggest resetting your parameters to the defaults (From the tools menu on the parameter page in QGC), then performing the setup steps in our instructions.

Parameters to check that can affect whether the thruster will spin would be
FRAME_CONFIG (should be Vectored/BlueROV2)
and MOT5_DIRECTION (needs to be Normal[1] or Reverse [-1])