Home        Store        Docs        Blog

Struggeling with controls


(Thorleif) #1

Hello.

I’ve just received a Logitech controller instead of an xbox, its much better centered and got a better deadband.

Anyhow, when i calibrate it, throttle up down, roll e.t.c. It is perfect on the “joystick” panel. But as soon as i ARM the “ROV” and try to push throttle both motor 6 and 5 starts going. Noone else, if i then try to inc trim_roll i also only get motor 5-6 ouput. Is there i way i can manually remanage the outputs? Seems like they are off somehow.

If i try to move the “PITCH” stick it moves thruster 1,2 and 4 and 3 does “twitch” a bit but not a lot. Is there a way to manually run one and one thruster with qgroundcontrol ? (servo output) and check if the problem is there somewhere? I did actually put them in correct order according to the docs but i dont understand. Might have “f’d” up somewhere.

What wierds me out is that throttle STICK moves thruster 5 and 6 perfectly. but if i reverse thruster 5 and 6 with RC5_REVERSE (i think) it dosent reverse. And when i trim the ROLL it also runs 5-6? Which dosent match, roll + throttle runs the same thruster output? :confused:


(Thorleif) #2

Update: I changed “mot_5_reverse” and mot_6_reverse and both upwards thrusters reversed. So its correct on the speed controller, something are not right here! :stuck_out_tongue: Someone got a perfect qgroundcontrol param list or know exactly what happends??


(Rusty) #3

Hi Thorleif,

I’m sure we can get this figured out quickly. First of all, vertical and roll do use the same motors. You shouldn’t have to touch roll trim for the most part, but if you do, the ROV will use the left and right vertical (throttle) thrusters to roll.

You should not touch any of the RC* settings. If you haven’t already, change the RC5_REVERSE and RC6_REVERSE back to normal. The motor directions should be changed with MOTx_DIRECTION as you found later.

You can download a “perfect” parameter file here: http://firmware.ardusub.com/parameters/latest/bluerov2.params. I just made that today, so please let me know how it works.

-Rusty


(undersearobotics.com) #4

@Rusty - That parameter file might be worth posting are the ArduSub website. :slight_smile:


(Rusty) #5

@undersearobotics.com True! It’s posted!


(Thorleif) #6

I’ll try the file as soon as i get renovation on the room done, currently the ROV is … somewhere under all the stuff :stuck_out_tongue:

A little extra question: When i test the thrusters is it ok to “spin them” slowly 5-10 seconds to see they move? When is it “bad” for the bearings? Whats the limits on dry land? Or how is it? :stuck_out_tongue:

 


(Rusty) #7

Thorleif,

You can definitely run the thrusters for a few seconds at a time. The thing you want to avoid is running fast for long enough that the bearings could overheat and seize up, which can happen pretty fast sometimes. Slow speed and/or short duration is fine.

-Rusty


(Thorleif) #8

Installed your params file, reconfigured joystick so when i move the left stick up thats “throttle”.

When i then thrust “forward” on left stick throttle moves forward. If i arm it and do the same, both thrusters thrust (only the up thrusters, motor 5 and 6).

If i change “mot_5_direction” to reverse and throttle forward the starboard side upwards motor reverses. So its correctly mapped it looks like? Am i just skipping a step maybe in the setup? Is “throttle” really up ? And elevator forward? Or :stuck_out_tongue: hehe


(Rusty) #9

Hi Thorleif,

Sounds like you might need to check out the joystick calibration instructions again. We just posted a clearer version of that directly on the BlueROV2 documentation, so please take a look here: http://docs.bluerobotics.com/brov2/software-setup/#joystickgamepad-calibration

Throttle is “up” (to stay consistent with the multicopter software that this is based on) and pitch is “forward”. We recommend calibrating the joysticks as described above so that throttle is on the right stick and forward on the left stick.

-Rusty