Home        Store        Docs        Blog

Temperature Sensor reading "ovf"


#1

Hey guys,

So my temperature sensor was working a few weeks ago, and then I bought the 5v-3.3v i2c converter because it was recommended on the site. When I run the program now, it just prints out “Temperature: ovf deg C”.

A continuity check showed that the vcc and ground were connected correctly, but there’s no connection between sda and scl on the conversion board.

My question is: is this an error in the board, or is my sensor fried?


(Jacob) #2

The SCL/SDA on the shifter won’t show as continuous, because of the shifting circuitry inbetween.

Has the sensor ever worked? If you connected it to an arduino without a converter, then it is damaged.


#3

Yes, the sensor printed out accurate temperature readings before we got the converter. So ovf is implying that the sensor isn’t sending data anymore because of the damages?


(Jacob) #4

Did you connect it to an Arduino without a converter? If so the sensor is damaged. This may or may not explain the ovf readings. Can you show us the output?