Software Updates

I’ve followed up with Todd, and the issue was resolved by allowing incoming connections through his firewall (Windows Defender).

8 posts were split to a new topic: Video Stream Troubleshooting

A post was merged into an existing topic: Video Stream Troubleshooting


I an really reticent in pulling my BlueROV apart again after checking the integrity of the seals. As a Mac user can I just update the QGC without having to take the ROV to bits again?



Yes, you may update QGC only. It is not strictly necessary to do the other (or any) updates, but it is advised.

I do understand your concerns. Please note that only one seal needs to be broken for this update, and we open our enclosures in this manner often without hassle in getting a good seal again. A major goal of this update was to prevent the need to access the electronics for subsequent updates.


OK Jacob, you have convinced me, thanks.


Well I bit the bullet and upgraded the whole system. Everything seemed to work correctly with full functionality from what I can see.

Two questions I have:

  1. How do you start recording video.

  2. I get this error message, should I be concerned.

To record video, click the red icon in the bottom right corner of the video window.

Regarding the warning, have you done the step to upgrade the Pixhawk to Ardusub 3.5? Do you see this warning after restarting qgc?

Yes indeed Jacob.

Ok, it looks like it actually failed to flash the pixhawk. Can you try again?

Maybe this needs to be more clear.

Hmmm, I am not sure where to start here. I tried flashing the pixhawk again but could never see my wireless network, just other peoples but the internet status says connected. I have tried flashing again and that seems to have worked.

Now I have see these error messages.

Plus I am seeing noticeable lag in the video. I am using an old MacBook Air though.

Ok @julesh, it looks like you are dealing with three separate issues.

‘Accels inconsistent’ this indicates the accelerometer calibration is not great. You can fix the error by recalibrating the accelerometers (advised), or by disabling the ‘INS’ pre-arm checks on the Safety tab of the Vehicle Setup page.

‘Lost manual control’ this is a failsafe mechanism, and the autopilot is letting you know what it has not received a joystick update for at least one second. If the autopilot is missing the joystick updates very often, it indicates a poor communication link between the ROV and the computer. This can be caused by loose wires, or by QGC having trouble keeping up with all of it’s tasks. QGC tends to slow down a little bit when switching between different views, which can cause this to happen on slower computers. You can increase the 1 second timeout from the Safety tab of the Vehicle Setup page (advised), or disable the failsafe altogether.

The video lag could be another symptom of the manual control issue (loose wires or slow computer). Can you describe the lag like how much delay there is, and what kind of frame update rate you see?


Hi Jacob

I have reverted back to an older version of QGC and my video latency seems to have improved. I have carried out another INS calibration and I am not seeing that error message any more.

However now, I have no lights. Functions 13 and 14 are taken up by trim roll inc/dec on the joystick (function and shift) and on the lights setup page, lights no 1 is channel 7 and lights no 2 is disabled.

I have reset the functions 13 and 14 to lights1_dimmer and lights1_brighter. That seems to have cured the lights problem.

Is there any way of rebooting the sub without powering it off and on please?


From the ‘Tools’ menu in the upper right-hand corner of the Parameters tab of the Vehicle Setup page.

Thank you very much Jacob.

any reason there is no video streaming after software update?

  • Did you do all three parts of the update?
  • Do you have a telemetry (vehicle) connection?
  • What operating system are you using?


Thanks for getting back, Jacob. I did completed all 3 parts of update. Im running on win10. Please see the screen shots below.

The movements of thuster works fine, only the video stream is not coming through.