Home        Store        Docs        Blog

Video Stream Troubleshooting


(jakkala kalvik) #1

I am not getting video from the pi does anyone have the same issue? I switched the pi cam and the ribbon cable with new ones still didn’t work. And the camera servo won’t move I switched it with a new servo and it didn’t work either.


Software Updates
Software Updates
(Jacob) #2

@jakkala-kalvik , can you go to 192.168.2.2:8088 and open a new terminal, then type ‘screen -ls’ and press enter. Can you tell me what it says after you enter that command?


(jakkala kalvik) #3

@jwalser

pi@raspberrypi:~ $ screen -ls
There are screens on:
689.file-manager (19/05/17 01:43:13) (Detached)
663.commrouter (19/05/17 01:43:13) (Detached)
653.webterminal (19/05/17 01:43:13) (Detached)
642.webui (19/05/17 01:43:13) (Detached)
630.video (19/05/17 01:43:13) (Detached)
615.mavproxy (19/05/17 01:43:12) (Detached)
6 Sockets in /var/run/screen/S-pi.


(Jacob) #4

Ok, now can you do screen -r video and show me the output? Did you have video working prior to the updates in the first post here?


(jakkala kalvik) #5

Setting pipeline to PAUSED …
Pipeline is PREROLLING …
/GstPipeline:pipeline0/GstH264Parse:h264parse0.GstPad:src: caps = “video/x-h264,\ width=(int)1
920,\ height=(int)1080,\ framerate=(fraction)0/1,\ parsed=(boolean)true,\ stream-form
at=(string)avc,\ alignment=(string)au,\ profile=(string)high,\ level=(string)4,\ c
odec_data=(buffer)01640028ffe1001027640028ac2b403c0113f2c03c489a8001000528ee025cb0”
/GstPipeline:pipeline0/GstRtpH264Pay:rtph264pay0.GstPad:src: caps = “application/x-rtp,\ media=
(string)video,\ clock-rate=(int)90000,\ encoding-name=(string)H264,\ packetization-mode
=(string)1,\ profile-level-id=(string)640028,\ sprop-parameter-sets=(string)“J2QAKKwrQD
wBE/LAPEiagA\=\=\,KO4CXLA\=”,\ payload=(int)96,\ ssrc=(uint)4262373409,\ timesta
mp-offset=(uint)2800445164,\ seqnum-offset=(uint)365”
/GstPipeline:pipeline0/GstUDPSink:udpsink0.GstPad:sink: caps = “application/x-rtp,\ media=(stri
ng)video,\ clock-rate=(int)90000,\ encoding-name=(string)H264,\ packetization-mode=(st
ring)1,\ profile-level-id=(string)640028,\ sprop-parameter-sets=(string)“J2QAKKwrQDwBE/L
APEiagA\=\=\,KO4CXLA\=”,\ payload=(int)96,\ ssrc=(uint)4262373409,\ timestamp-of
fset=(uint)2800445164,\ seqnum-offset=(uint)365”
/GstPipeline:pipeline0/GstRtpH264Pay:rtph264pay0.GstPad:sink: caps = “video/x-h264,\ width=(int
)1920,\ height=(int)1080,\ framerate=(fraction)0/1,\ parsed=(boolean)true,\ stream-f
ormat=(string)avc,\ alignment=(string)au,\ profile=(string)high,\ level=(string)4,
\ codec_data=(buffer)01640028ffe1001027640028ac2b403c0113f2c03c489a8001000528ee025cb0”
/GstPipeline:pipeline0/GstRtpH264Pay:rtph264pay0: timestamp = 2800445164
/GstPipeline:pipeline0/GstRtpH264Pay:rtph264pay0: seqnum = 365
Pipeline is PREROLLED …
Setting pipeline to PLAYING …
New clock: GstSystemClock


(Jacob) #6

The raspberry pi is streaming video. I think something is wrong on your computer with the network configuration, firewall, or antivirus settings. Make sure you have a static ip of 192.168.2.1, allow incoming network connections, and allow QGC access through firewall.


(jakkala kalvik) #7

I am running Ubuntu but I guess I will try windows and see what happens.


(Jacob) #8

Same rules apply on Ubuntu, it works on Ubuntu.


(jakkala kalvik) #9

Don’t know why it worked but I had a VM with windows changed the firewall settings and opened Qgroundcontrol. I was able to connect to the rover but it didn’t stream video. So I closed the VM and tried the Ubuntu version as sudo and it worked I am able to stream the video now. Thanks.