Home        Store        Docs        Blog

Gstreamer problems and tuto


#1

Hi everyone, i’m writing this post because i need your help and at the same time it’s going to help people who want to start with gstreamer.

First with my colleague and me, are teaching electronics in France in Marseille. Our high school is near the sea and we decide to design our own ROV to use it with our students :

Some part are in aluminum and metal, and other made by 3d print.

For the electronic we use Arduino and Raspberry pi for the camera. But we are total newbie on Raspberry pi.

So this is our problem. When i connect the Raspberry pi to the computer and start a pipeline with gstreamer i can see with the software wire shark the frame. So we now that the computer and the raspberry pi are connected and on the same network. this is the line we use on raspberry pi :
raspivid -n -t 0 -rot 270 -w 1920 -h 1080 -fps 30 -b 6000000 -o - | gst-launch-1.0 -e -vvvv fdsrc ! h264parse ! rtph264pay pt=96 config-interval=5 ! udpsink host=192.168.0.2 port=5700

But when i start GStreamer on windows with this line:
@echo off
cd C:\gstreamer\1.0\x86_64\bin
gst-launch-1.0 -e -v udpsrc port=5700 ! application/x-rtp, payload=96 ! rtpjitterbuffer ! rtph264depay ! avdec_h264 ! fpsdisplaysink sync=false text-overlay=false

this happen:

I install the two packages :
gstreamer-1.0-devel-x86_64-1.5.2.msi
gstreamer-1.0-x86_64-1.5.2.msi

Do you now why i have got this error and how i can solve it?

Thank you in advance !!


#2

The plan of the Rov


(Jacob) #3

Hi Adrian, you don’t have any errors! This pipeline will open a video window on the receiving end (tested with your sending pipeline):

gst-launch-1.0 udpsrc port=5700 ! application/x-rtp, encoding-name=H264, payload=96 ! rtph264depay ! h264parse ! avdec_h264 ! autovideosink

If you don’t see video, then check that the target ip on the sending end (the udpsink host) is the ip of the receiving machine. If it still doesn’t work, make sure you have your network configured correctly.

-Jacob


#4

Thank you Jacob for your help !!

I check the parameter of the network and everything look okay. With the software Wireshark i check the frame on network:


As you can see the IP of the PC is 192.168.0.2 and the Raspbery pi 192.168.0.3 and the PC receive data on the internet port number 5700. So i don’t understand why the window with the video don’t want to open?

I’m working on windows 10. I try to reinstall gstreamer but nothing change.
So i’m totaly lost and don’t see other solution…


(Jacob) #5

Do you have a firewall or antivirus running?


#6

Wow, how fast you are !! thank you !!
I ve got Kaspersky and i think that the firewall of windows is running.


(Jacob) #7

I would start there, sometimes you have to grant individual applications or programs access.


#8

Man i am so thankful !!! It’s work!!!

I disable the firewall and the video appear. I don’t know were you are but if you come to Marseille i’ll pay you a drink.

Thank you so much !!!