Cannot get video

I’m seeing identical symptoms to this post here:

However a fresh install does not fix the issue for me. Any thoughts on what I can do here?

I have checked from ssh terminal and I can see the camera connected via USB. I’ve also used terminal commands to verify that I can not only capture from that camera to disk but also stream it with no problem using the following:

pi@blueos:~ $ gst-launch-1.0 v4l2src ! videoconvert ! x264enc tune=zerolatency bitrate=500 speed-preset=superfast ! rtph264pay ! udpsink host=10.0.0.88 port=5000
Setting pipeline to PAUSED …
Pipeline is live and does not need PREROLL …
Pipeline is PREROLLED …
Setting pipeline to PLAYING …
New clock: GstSystemClock
Redistribute latency…
^Chandling interrupt.0:01:15.4 / 99:99:99.
Interrupt: Stopping pipeline …
Execution ended after 0:33:04.194178627
Setting pipeline to NULL …
Freeing pipeline …

I can then open that stream from the command line on my macbook with no problem and view the camera. When I go into the blueOS web UI however, it shows:

It looks like there’s no video stream accessible from your device’s detected IP address (10.0.0.88).

And only lists the redirect.

If I enable pirate mode I can see the camera but attempting to create stream on it fails with timeout. The page also refreshes on its own from seeing the different ‘devices’ to seeing No video-devices available…the same as in the other topic.

Any help is greatly appreciated.

Wanted to give this a bump. Anyone else unable to get video?

Hi @fatal3rr -
You probably have a camera that has failed - this has been a frequent issue for us lately. Please use our support form to share order information to obtain a replacement. Thanks!

This isn’t a camera from you guys, they’re just standard USB cameras. I have tried 3 different cameras, all with the same result. Additionally, it can’t be just the camera because I can, from the same RaSpi4 stream that camera from the command line with no problem, it’s something going on in the software. I’ve tried 2 generic usb cameras and a logitech pro stream webcam, all same results.

-Mike

Hi @fatal3rr -
Can you confirm the cameras you’re using are compatible with the standard UVC driver? Do they output H264 format video? If not, they may not be compatible with BlueOS.
Can you also share what version of BlueOS you’re using currently? Updating to the latest 1.2 beta4 may be helpful.