Software Updates

Hello Jacob,

Thank you for looking into this. I retyped my credentials and waited a few minutes for the internet connection. Still no luck. Attached below is the webui log.

Thanks for the help,


webui.txt (234.9 KB)

It’s connecting and getting an ip in the middle there from the belkin router, but the ping command isnt seeing a gateway or a dns or something when it tries to ping google. Id blame the belkin router just because i hate them.

I think Tim is right about the DNS, and if so, something’s up with your router. Try this:

  • Go to
  • Click the button in the upper right to open a new terminal window
  • Paste this command into the terminal and press enter:

sudo sh -c ‘echo nameserver > /etc/resolv.conf’

  • If your issue is simply DNS, then it should be resolved! Go back to the WiFi page and see if it is happy with the internet connection now.


Hello Jacob,

Thanks for the help! That fixed my internet connection and I have now been able to update the pixhawk. I am noticing that the updated Qgroundcontrol is now very laggy with the video. This is something I noticed when I tried ardsub3.5 RC1. Reverting back to 3.1.3 of Qgroundcontrol fixes the issue.

Also, how can I flip my camera? Before I was able to access those settings with
nano /home/pi/companion/RPI2/Raspbian/

I appreciate the help. Great work.


Hi Ryan,

I too, am seeing video lag. Does QGC version 3.1.3 support Ardusub version 3.5 ok? If so, I’ll try to downgrade QGC as well.


Hey Ken,

Most features seem to work ok in 3.1.3. I setup all of my parameters in the latest version of GGC and then downgraded to 3.1.3. Trying to open the camera servo settings in 3.1.3 crashes QGC. Hopefully someone has a solution to flip the picam with the latest image.



@k.deboer @rdn11180 Can you please provide some information about your computers (Settings->System->About) and potentially participate in some testing here? This problem seems to occur on only a few computers, but what it is about those computers, I haven’t figured out yet.

Please also try these steps and let me know if anything changes:

  1. Uninstall QGC
  2. Delete the qgroundcontrol directory at C:\Program Files (x86)\qgroundcontrol
  3. Reboot the computer
  4. Install QGroundControl

QGC 3.1.3 will work with Sub 3.5, the but some of the stuff in the setup page won’t work (notably the camera tab like Ryan mentioned). The settings can still be modified through the parameter editor though, so rolling back will be ok as long as you are aware of that limitation.



Navigate to


These settings aren’t persistent between boots, that will come in an update. Also, that -roi option doesn’t belong.


Hi Jacob,

Regarding the video lag. I tried 3.1.3 with my laptop. The lag was much better. I will attempt to send you the details of the laptop. In the meantime, it’s a HP EliteBook 8470p. Intel i5 2.60GHz, with 4 GB RAM I’m sorry, I had never checked before, but the screen resolution is only 1600x900.

I then grabbed a different computer. An HP 840 G3. i5, with 4 GB RAM. Screen resolution is 1920x1080. I installed the recommended version of QGC Development version 2017-04-23. No video lag at all. Looks like I’ll be looking to buy a new computer.

Thanks again for your outstanding support!



I forgot to mention. I did a full uninstall of QGC,reboot, re-install of the Dev 2107-04-23 QGC. Video lag was still observed. QGC version 3.1.3 didn’t.


Thanks Ken,

This feedback and details are valuable in this sort of situation.


We also have major lag problem. Tested on Lenovo Yoga Pro3 and Lenovo Yoga 14. :frowning:

Hello Jacob,

The new Pi interface worked well for changing the orientation of the camera. Thank you for that. Like k-deboer, I have tried several different combinations of uninstalling/reinstalling of QGC and still have to revert to 3.1.3. I have been using an ASUS X200M Intel Pentium N3520 2.166GHz Quad Core with 4GB RAM for the groundstation.

I was able to dive today and can confirm that Ardsub 3.5 works great with QGC 3.1.3.

Thanks again,


OK, after many hours of reconfiguring and updating, long story, I too was having the video lag issues with the newest QGC- 2-3 secs. Had issue on a few laptops, rolled back QGC to 3.1.3 and video is fixed. Hope the issue can be resolved, was really like the new features in the latest QGC, namely the temperatures.

I’ve invited those with issues on windows to a conversation where I have provided some experimental installers to find the cause of the issue. Initial feedback is good, we may be close to a fix. @shannon I’ve just invited you to join.

1 Like

4 posts were split to a new topic: Gyro not calibrated warning, loss of control

I went through the software updates according to instructions. I tried to navigate to I also tried to navigate to Go to as you instructed above. I cannot navigate to either of the sites, I get a timed out error message. Am I doing something wrong?

Hi Todd, you may have just mistyped it here, but the first address should be

These are web pages hosted by the Raspberry Pi on the ROV, so the ROV must be turned on and connected to the computer in order to see them. If you’ve done that and still can’t see the sites, do you see video/telemetry in QGC?


No Jacob I am not seeing anything. No video or telemetry.

Hm, it sounds like the SD card is not reading, or was not imaged correctly.

Try turning the ROV off, then remove the SD card and re-insert it firmly. Then turn the ROV on, if you see the green light near the SD card and red light on the Raspberry Pi blinking periodically, then the Pi has booted up and is running.

If the green light is not blinking, then there was a problem booting from the card, and you should try writing the image to it again.