Software Updates


QGroundControl installs 3 shortcuts, QGroundControl, QGroundControl (GPU Safe Mode), and QGroundControl (GPU Compatibility Mode). Please try each of these and let me know your results using each one.

It also looks like you have downloaded QGC from the QGC website instead of the links on our website, and in the first post of this thread. I am hosting our own builds of QGC in order to keep it up to date with the changes we make.


Hi Jacob,

I tried other laptops and the new version of QGC works. It only failed on one computer. Is there any computer system configuration you are aware of that would stop the video stream coming through? Already checked window firewall and QGC is permitted.

@305155973, Did you try the GPU Safe and GPU Compatibility modes mentioned in my previous post? QGC is incompatible with a few pieces of graphics hardware, so one of these other modes needs to be used.

The safe mode works! thank you so much, Jacob. However, the compatible mode does not work.

Another issue, what does the image below mean? It showed up when I tried to arm the joystick.Pre-arm check failure

Plus, this is the safety setup I use:safety setup

Hi Jacob, do you have a list of graphics hardware which are incompatible with QGC?

I am picking up new laptops and try to avoid those built with these incompatibles.

thank you

I use this laptop to my Bluerov2:

ASUS ROG GL753VE 17.3" Full HD matt
(GeForce GTX1050Ti,Core i7-7700HQ,16GB RAM,256GB SSD,1 TB HDD,DVD±RW,Win 10 Home)

Have no problem with QGC.

1 Like

@305155973 I’m sorry, I don’t have a definitive list. In these situations, QGC just needs to be forced to use a different graphics driver by choosing a different launch shortcut. I have never seen a case where a computer was totally incompatible with QGC.

It is failing a gps position check because you have selected ‘All’ for the arming checks. You should only need RC, board voltage, and battery level.

Thanks a lot, Jacob.

Hey Jacob,

I just finished building my new BlueROV 2. Tried to connect it to my PC, however I’m a little lost where to go from there. I booted up the latest QGroundControl, but the ROV doesn’t seem to connect. Is there a step that’s missing in the manual? Do I have to do these updates before being able to connect to the ROV? I’ve set up the ethernet like the manual stipulates.

Nothing is missing in the manual that I am aware of. I just added a note that anyone who purchased their ROV after June does not need to do these updates.

What OS are you on? Did you set up you IP address on, and allow QGC access through your firewall? You may also need to allow incoming connections through the firewall. If you continue to have trouble, please download TeamViewer, and contact me at

Best - Jacob

Hey Jacob,

I sorted it out. Had to tick all the boxes for the firewall (only had the first one ticked).

I had the high video delay issue, so I went back to the older version of the software, now I’ve got a motor issue (discussed in the appropriate subforum).

Hello Jacob.
Sorry to be a pain. Do you recall my system has a router conflict with the IP address for performing updates?
Do you recall what IP address you used to access my system?


Check the etherenet interface settings on your computer. I probably used 192.168.x.2, the x will be the same as your computer. is listed in my details

So try in the browser. You will need to update the ‘host’ in the gstreamer sections to be after the update.

I met a problem which I can not flash my pixhawk through the WEB

it shows Internet status is not connected
but my wifi is connected
what should I do?
thank you

You can try restarting your router. What model is your router?

You can also do offline updates by uploading the update content from your computer to the ROV.
Here is the Pixhawk firmware.
and here is the companion update file.