Home        Store        Docs        Blog

Software Updates - September 14 2017

(Oystein Skarholm) #22

Ok, so all of them is part of the same system, thanks :slight_smile:

(Jacob) #23

Correct. They are each an individual component of the entire system. All of these components are required to operate the BlueROV2.

(Julian Hancock) #24

Thank you very much Boko.



@jwalser, how is the “boat” GPS location sent to QGC? Can I set a fixed “boat” GPS location/heading?

(Jacob) #26

The driver for the Water Linked Underwater GPS system sends mavlink messages with the boat position to QGC. This make the boat identify as another mavlink vehicle to QGC.

We are working on a more generic implementation.

(Oystein Skarholm) #27

II have installed the new QGC version (not currently conected to the ROV. The only visible window to me is the map window. The arrow to click to change between camera view and map view is not there. How do I toggle between map an camera now. (PS I uninstalled the “old” QGC before installing the new updated version. (For info )

(Jacob) #28

Click the ‘Q’ Icon, and at the bottom of the General Settings tab, select ‘UDP video stream’. This should have been the default, I will be doing a small update to QGC soon to fix this to be the default.

(Terry Eglinton) #29

Just completed the update for QGC, Raspberry Pi and Pixhawk. I had an initial AHRS issue, but recalibration level resolved that issue, but I have also lost the camera stabilisation. I have ticked / unticked the box, rebooted several times. Any suggestions? - thanks.

(Jacob) #30

@Teggles Camera stabilization functionality was broken in the 3.5 release of ArduSub a few months ago. It has not been fixed yet. I’m aware of only one other person who was using this feature, have you tried operating without it? You can track the progress of this issue here.

(Terry Eglinton) #31

That’s a shame, it was working fine before the update. Camera tilt is also a bit hit and miss, sometimes works, sometimes not. Could they be related?


Is there any way to disable the auto delete funktion in QGC? This is a very dangerous feature! To now, I lost 3 recordings… :’(

(Jacob) #33

@Mikxie We’re working on it. I am sorry that you lost the video.


Thank you very much Jacob :slight_smile:


I just discovered that QGC is deleting videorecordings if more recordings are done with only a short interval between them.

(Jacob) #36

@Mikxie, this is what is happening. You can read more about it in my original posts up top ^^.


No it is a different problem. If I record a video, stop recording and restart recording, the first of the two is deleted.

If I by mistake double-clic the record button when I want to end recording, the video is lost.

(Jacob) #38

Ok @Mikxie, thank you for clarifying. We are working to change this asap, we should have another revision next week. You can track the progress here.

(Jacob) #39

(Doyle) #40

any way to change the screen from"Altitude" to “Depth”?

(Terry Eglinton) #41

Hi Jacob,
I am having a number of issues after the upgrade now. I can only run QGC in safe mode. If I try to load it normally it takes an age (hard drive going flat out) and all I have is a frozen picture from the camera and no functionality. In safe mode its fine (a little slow) but no camera tilt. I have tried reinstalling QGC, but no difference. It was all fine before, any ideas?