Home        Store        Learn        Blog

Setting up RPi and Pixhawk from scratch

Hi
I am trying to set up a tabletop version of the BR2. I have a locally purchased RPi and a Pixhawk from BR
When connecting the RPi to the computer via USB and Pixhawk to the RPi via usb cable, the Pix do not light up.
Is there a different way to set up the RPi and Pix if not already prepared by BR?

Note:
I has come to my attention that I can not use a RPi 4. I am changing back to RPi 3B+.
The question still stands though. Is the software set-up guideline sufficient to get the RPi and Pix + USB cmera to show in QGC?

Hi @SDI!

I believe this might be a power issue. Can you try powering the PI with our BEC or a good usb power source?

Definitely a power issue, I power them both with external power supply else pixhawk will not light up.

I went about and replaced the RPi 4 with a RPi3 and connected it all up in the same manner. The PIX lid up like a X-mas three. :slight_smile:

Still no connection with the Pi. Both Pi and PIX have power and light. Do I need to set the Pi IP adress somehow?

Note: I etched the Pi image onto the sd card. When the sd card is in the Pi, the PIX do not turn on.

Since this Pi is new and purchased locally, is there something special I must do to set it up?

Also, I am trying to update the pix by connect it directly via usb to the computer to update it through qgc, but QGC does not find it.

You still need to connect the Ethernet cable and have both pixhawk and pi loaded with the software.

Fyi if you are only wanting to connect to the control system you don’t need the pi.

Qgc will detect the pix even if only connected via usb.

Etienne
Thanks for your answer. The ethernet cable, the access thorogh the firewall, ip address 192.168.2.1 for the ethernet connection is in place.
I tried to connect the PIX directly into the PC to update it through QGC but it looks like QGC don`t register it.

Figured that one out. The usb, even almost new, was damaged. Changed the USB cable and changed ethernet cable as well.
I reconnected the PIX to the PC and QGC recognized it. I was able to update the firmware.
The RPi, however does not want to come out and play.