Home        Store        Docs        Blog

Pixhawk Powers Up, No Connection in QGC, USB Not Recognized


(John Stahl) #1

Good morning,

I have been having an issue with trying to get the Pixhawk to connect to QGC. I have had it working many times in the past, zero issues. Now we have been working on a way to power the Raspberry Pi and Pixhawk internally using 5V regulators at first, then moved on to using the BEC from the ESC’s. Not sure if the power source change caused our problems, but after the switch we noticed that it no longer works.

Raspberry Pi works like a charm. I get video feed in QGC. I have bidirectional pings with 0 packet loss. Raspberry Pi is being powered with MicroUSB spliced into motor 5 BEC.

Pixhawk is being powered through the power module port on pin 1 (+5VDC) and pin 5 (GND), going left to right. Not using the included power module because it gets WAY too hot for some reason, so we ditched it. Grounds are all connected to the GND rail on the Pixhawk, this includes GND from Pi, Pixhawk, and all 6 ESC’s. Pixhawk appears to start up fine.

FMU lights: PWR - Solid Green, B/E: Quick red flash for 1-2 seconds.
Main LED indicates standby.

When the Pixhawk is plugged directly into the computer via USB cable, the same start up LED sequence. Windows tell me that the USB device is no recognized. Device manager tell me that the most up to date driver is installed. I have also reinstalled the PX4 drivers from https://pixhawk.org/firmware/downloads. Successful install of that, still no recognition of the device.

Please help me.


(Jacob) #2

Hi I have seen this situation once in the past, and it happened when I wired the power backwards. After correcting the wiring, everything on the pixhawk appeared to work except usb communication.

Can you go to the device manager and see if a COM port appears when you connect the pixhawk? Can you also see if it is possible for you to reflash firmware with QGC?


(John Stahl) #3

Hi Jacob,

I checked the wiring and everything appears to be connected correctly. One UBEC PWR wire goes to pin 1 and the same UBEC GND wire goes to pin 5 on the “Power” port on the Pixhawk. Would it be better to power the Pixhawk off the servo rail? I know this is a backup, but something caused this and I don’t know what yet.

I have tried to reflash with QGC, but the Pixhawk isn’t recognized by the computer, so I cant reflash due to it not seeing the Pixhawk. I do not get any COM port in the device manager, the only thing that I get is a failed device in USB controllers (image included).


(Jacob) #4

That sounds like it’s shot. What’s the voltage output on the UBEC? Maybe the hot power module is at fault, what’s the voltage on each of the outputs on the power module?


(John Stahl) #5

Yeah we did buy a new Pixhawk. However, I don’t think it is a hardware issue. We placed the SD card from the old Pixhawk into the new Pixhawk and it wouldn’t recognize the new Pihawk when plugged in. However, with the new, blank SD card it loaded just fine. So not sure what problem we had, but I think it had something to do with the SD card.