Home        Store        Docs        Blog

Is my Pixhawk dead (no heartbeat, no USB)?

(Peter Graven) #1

Lightly used (under 24 hours of use) pixhawk (purchased w/ BlueROV2 Enclosure Only Package) last year. At our last demo at a local MakerFaire, the ROV quit working and the heartbeat stop blinking and we lost connection. We have pulled the pixhawk, tried to direct connect to a computer and it’s not recognized. Pulled out a spare and was able to flash the card, replaced it into the nonworking pixhawk and still not operational. With no heartbeat and no USB connection, is the pixhawk dead (even by itself and plugged into the computer), the pixhawk is warm to the touch.

Please advise… is there a reset I can do or tricks to getting the USB to be recognized?

(Peter Graven) #2

(fmu)
PWR - solid green
B/E - no light

(io)
PWR - solid green
B/E - orange
ACT - flashing blue

no heartbeat

(Jacob) #3

It sounds like the autopilot is toast. Some things just to be sure:

Measure the voltage between the two outermost pins on the power module connector (pin 1 and pin6). The voltage here should be 5V. We have seen some power modules fail in the past and begin passing the whole battery voltage to these pins.

Do you see anything in device manager on the computer when you plug in the pixhawk? Does the FMU B/E led ever illuminate?

Contact support@bluerobotics.com about getting replacements under warranty.

Also, do you have any pictures of your MakerFaire demo? (:

1 Like
(Antonino Bono) #4

Something similar has happened to me.
BlueRov purchased in January and first time on the water. Everything is ok for the first twenty minutes but then he started behaving abnormally. In surface water he started to turn on the engines and the lights by himself without giving them any commands. He was crazy. Then he started re-starting continuously until I pulled him up and unplugged the battery. Once the power was turned back on, the robot started up with a single beep but the Pixhawk didn’t turn on. No communication with the PC and no video. At home you tried to check all the connections but nothing. I also tried to reinstall Ardsub on the SD without success.

1 Like
(Peter Graven) #5

you can find photos from our Maker Faire Demo and others on our FB page at https://www.facebook.com/sfrobotics/.

(Peter Graven) #6

I’ll reach out to support tomorrow as well.

(Antonino Bono) #7

I think it’s the power sense module. The Pixhawk works if connected to the PC. I measured the voltage between two outermost pins on the power module connector (pin 1 and pin 6) and there is no voltage. I tried to change usb cable between Pixhawk and Raspberry but it doesn’t work. No video connected to the PC. If I measure the voltage at the terminal block it is the same as the battery.

Once the power was turned back on, the robot started up with a single beep but the Pixhawk didn’t turn on:

If I connect to the PC, battery disconnected:

Usb cable between Pixhawk and Raspberry, battery connected:

(Willian Galvani) #8

Are the raspberry lights turning on? If not, check if there is 5V coming out of the UBEC.

1 Like
(Antonino Bono) #9

No light on the raspberry, no voltage output to the Power Sense Module (PSM)
The UBEC like this 5V 6A Power Supply I measure 1.8 Volt

(Willian Galvani) #10

This is probably the issue. is it hot?
Something might have drawn too much current from the UBEC, damaging it.
Try replacing it and looking if there’s anything else that could be wrong on the 5V bus in the Pixhawk (like a stuck servo).

(Peter Graven) #11

In our case, the Pixhawk does get really hot. We have replaced the Pixhawk and since have not had any issues in testing the ROV.

(Antonino Bono) #12

Power sense and UBEC are not so hot. Instead one of the 6 ESC’s is very hot. It is the one connected to the thruster 2. The propeller seems a little harder to turn. I tried to unplug the servo one by one but it didn’t change

(Willian Galvani) #13

Get another UBEC, that one is probably gone.
As for the hot ESC, have you tried disassembling and cleaning the thruster? Diving in water with too much ferrous sediment sometimes causes some of it to get stuck to the magnets. This should not have anything to do with the UBEC failure, though.

(Antonino Bono) #14

This is the last photo of the water test 2 seconds before the robot has had problems.
The thruster was a little stuck. It was loose the shaft collar set screw and I lubricated everything with wd40

(Jacob) #15

It’s ok now?

(Antonino Bono) #16

All solved changed UBEC and seems to work. I also had an ESC failure of the thruster 2 that burned out. I made plugs with the Blue / White / Green wires of another thruster and it works without heating. I just to try at sea if everything still works to perfection.
Thanks to BlueRobotics and its staff for helping to solve the problem.