Home        Store        Docs        Blog

BlueROV2 Advanced - First Connection Help


(Mark Langille) #1

Just finished our assembly for the BlueROV2 Advanced system and now working on getting it connected to Windows and QGroundControl.

Couple questions:

  • Does the Advanced system ship with the Pi3 and Pixhawk preflashed and ready to go? ie is there anything needed to be done before connecting?
  • Anyone have nay instructions on the setup for the Ethernet connection under Windows 7?
We set the IP as noted but cannot seem to get any connection in QGroundControl Seem to have activity on the Tether LAN lights when powered but that is as far as we get.

Any tips or suggestions would be appreciated.


(Rusty) #2

@schoonerlabs

Cool! Glad it’s going well so far.

The Advanced Electronics comes with an SD card for the Raspberry Pi that is preflashed. The Pixhawk is not flashed at all so you’ll have to do that. I would recommend doing it with a direct USB connection to your computer.

For IP setup, here are instructions: http://www.howtogeek.com/howto/19249/how-to-assign-a-static-ip-address-in-xp-vista-or-windows-7/. For ArduSub, you need to set the computer’s IP to 192.168.2.1. You don’t need to set the gateway or subnet mask.

Let me know how that goes!

-Rusty


(Mark Langille) #3

Ok great thanks, wasn’t sure if Pixhawk was ready to go or not. I assume that is why I have no connection :slight_smile:

I’ll start there and see how it goes. Is there a reference for the Pixhawk flash process? I’m use to Pixhawk with Mission Planner for UAVs but not QGroundControl so just curious on the procedure.

 


(Rusty) #4

Okay. Here’s a guide to flashing the Pixhawk firmware: http://ardusub.com/initial-setup/#loading-firmware-on-pixhawk

-Rusty


(Mark Langille) #5

Also which firmware is suggested?


(Rusty) #6

I would recommend the most recent vectored version: http://firmware.ardusub.com/Sub/latest/PX4-vectored/


(Mark Langille) #7

Managed to flash the Pixhawk fine and it connects via USB.

Still no connection via tether. I can ping 192.168.2.2 fine so it seems to be connecting to Pi3 ok.

Is there anything else special required for QGroundControl to see the Pixhawk over the tether?


(Rusty) #8

You might have to turn off the Windows firewall if that’s an option. We’ve had that block the connection in the past. Let me know if that works, otherwise I can provide more debugging steps.

-Rusty


(Mark Langille) #9

Yes firewall was the issue, was just about to post that we resolved that.

Now to get the video feed working, getting closer.

Will try and put a post together on these issues and work around once we get it fully working.


(Mark Langille) #10

Everything setup and seems to be working now including joystick but still no video.

Is there a simple way to check that the camera is working properly on the Pi3? Or some other means?
Wondering if it may be a camera or ribbon cable issue perhaps.

Or if there is some other PC side settings to check?


(Rusty) #11

@schoonerlabs - We’ve been getting mixed feedback about video on Windows 7. It seems to be working for some but not working for most. If you have any Windows 10 / Mac / Linux computers available I would check on there just to make sure everything is working.

If you log into the Raspberry Pi you can run some commands to check if the camera is connected. I’d be happy to walk you through that if you want.


(Mark Langille) #12

I’ll have to track down another laptop, for some reason QGroundControl just hangs on my Mac, never seems to load.


(Mark Langille) #13

Ok QGroundControl now working on Mac and connecting to BlueROV2. Had to update to Yosemite as it will not run under Lion I had on my old Mackbook.

But still no video so looks like it wasn’t a Windows 7 specific issue.

Anyone have suggestions on how to test to see if the camera is connected and working and how best to track it down?


(Rusty) #14

@schoonerlabs - Okay. Thanks for testing that. First thing to try is to make sure the camera cable is connected in the right orientation and securely connected. I would disconnect it and reconnect to make sure it’s seated properly. You’ll have to power-cycle the ROV after that to test for any improvements.


(Mark Langille) #15

Tried that but no luck.

Would it be worth redoing the Pi SD card in case something is out of whack in the setup?

When I do a port scan from Mac to Pi IP I only see telnet port open.


(Mark Langille) #16

Issue resolved, cable was in the wrong way around. We had oriented it based on the cable labeling, however on our cable the blue tab and labeling are on same side and we had it to the HDMI port.

Basically should always be blue tab to the ethernet port.

Thanks for all the help. Now to do the final cleanup of some wiring and seal things up for water testings.


(Rusty) #17

@schoonerlabs - Excellent! Glad it’s working.


(Maureen Byrne) #18

I have the same problem. I’ve successfully flashed the pixhawk, got a ping from the raspberryPI, set the IP adress for the computer and tried to get a connection with and without the firewall on. But QGroundControl has no connection, any idea on what I might be doing wrong? Both the interface boards light up with power and signal.


(Jacob) #19

Maureen, it sounds like you have not configured the raspberry pi to start the mavproxy script at boot.

Please ssh into the raspberry pi and post a reply with the output of the following commands entered on the raspberry pi terminal:

‘sudo screen -ls’

‘cat /etc/rc.local’

‘cat /home/pi/companion/RPI2/Raspbian/start_mavproxy_telem_splitter.sh’

 

-Jacob


(Maureen Byrne) #20

pi@raspberrypi:~ $ sudo screen -ls

No Sockets found in /var/run/screen/S-root.

 

pi@raspberrypi:~ $ cat/etc/rc.local

-bash: cat/etc/rc.local: No such file or directory

 

pi@raspberrypi:~ $ cat /home/pi/companion/RPI2/Raspbian/start_mavproxy_telem_splitter.sh

this starts mavproxy so that the serial link to the companion computer (on /dev/ttyACM0)

is available to a companion computer and external GCSs via UDP. This broadcasts so that

multiple IP addresses can received the telemetry.

 

For PixHawk or other connected via USB on Raspberry Pi

mavproxy.py --master /dev/ttyACM0,115200 \

–out udpin:localhost:9000 \

–out udpbcast:192.168.2.255:14550

pi@raspberrypi:~ $  

-bash: syntax error near unexpected token `&’