Relay integration with the navigator board

Hello

Recently I was playing with moving a machine from the pixhawk to the navigator board, but during the switch I noticed that I could not get the relay parameter for the navigator board (at least as far as I can tell, QGC only shows support for the pixhawk and bb blue on the relay parameters). Now unfortunately for me, this was important to actuating on and off a board I am sending the signal to, since the minimum pwm doesn’t turn off the board when using servo_function.

Is there any way to emulate the relay function with the navigator board or get the relay parameters to work with the navigator board?

1 Like

Noticed how the hardware page for new Navigator mentioned how relays are not supported yet but coming soon. Just curious if we have a expected date for relay integration?

1 Like

I’m not certain, so I’ve asked internally and will get back to you :slight_smile:

1 Like

@Jnyberg, it’s a high priority but the software team is stretched really thin at the moment.

Depending on when time is available it could be done within a week, but we’re hoping for within a month or two :slight_smile:

1 Like

Hi @Qlowe, welcome to the forum :slight_smile:

I’ve moved some other comments here that are on the same topic. In general, we haven’t yet finalised the relay functionality on Navigator yet -

I think last I heard we had a seemingly working firmware test branch, but it needed some more testing before release. Our software team is small, and there are a couple of other features that are being finished off first. I’m hopeful relay support will be sorted out some time within this month :slight_smile:

Hopefully this week or next - we have a working solution (which I was testing this morning), so now we just need to clean it up and make sure it’s easy to use, then make a release.

it sounded very good,then I just have to wait to reassemble enclosure :smiley:

You can track the issue (and corresponding pull request) here :slight_smile:

Currently the behaviour is working well for relays, but some of the other ArduPilot developers have requested some changes that would allow it to support more general digital output purposes instead of just relays.

Just following up on this, based on my following of the pull requests, is this likely to be ready soon?

Indeed. It has been merged into the master branch (so should already be available if you install the “development” firmware), and will soon be backported to Sub-4.1 and released via a minor release.

I’ll comment here when 4.1.1 is out (not sure if it will be beta or stable), which will hopefully be before the end of next week within a couple of weeks :slight_smile:

EDIT: Increased time estimate, because there are some other minor tweaks being included that are unrelated to relay integration.

Following up, 4.1.1-beta1 is now available, with Navigator relay support! :slight_smile:

1 Like

I have now upgraded to 4.1.1 Beta,but does not get the relay to work on Navigator boards.



I have connected the SSR phidgets relay 1 to PIN 15 and the second SSR phidgets relay 2 to PIN 14 on Navigator boards.

In joystick settings i have Button 14 to Relay_1 toggle and Button 15 to Relay_2 toggle.

In Relay settings i have Relay_pin and Relay_pin 2 to AUXOUT1 and AUXOUT2,something is not right here.

Shall it be AUXOUT4 and AUXOUT5, if i use PIN 14 and Pin 15 on Navigator boards?

Is there anything else I’ve forgotten settings?

Navigator does not have any AUXOUT pins. QGroundControl has not yet been updated to know which options to present for the Navigator, so when specifying the relay pin you’ll need to select “Advanced settings” and “Manual Entry”, then just put the pin number you want to use (e.g. for pin 14 you can put the number 14) :slight_smile:

1 Like

It works now,thank you very much :smiley:

2 Likes

Is there a limit to the number of the Servo Rail/PWM Outputs that can be set as relays?

While there is no limitation of Pin numbers per say, ArduSub only uses 6 relays for now. additionally, we only support controlling 4 via joystick functions.

1 Like

I have a relay mapped to channel 11 with the Joystick function set to relay_1_momentary.

If I keep the joystick button pressed from between 5 to 10 seconds, the relay will stay latched and the vehicle loses manual control.

If I’m in the Joystick Setup window of QGC, it will change to the Summary page, and the Xbox controller gives a haptic feedback vibration.

Not sure why that would be the case, and isn’t something I can replicate.

That sounds like it may be functionality of the controller itself. Does it show the same behaviour when assigned to a different button?

It does it on different buttons and channels. It also does it with Servo Momentary Min and Max commands.
I’ll get a different joystick controller and see if I can replicate it.