Relays on Navigator

We are trying to add some auxiliary functions on one of our BlueBoats. We wish to be able to turn on/off auxiliary lights and sirens via the joystick controller. I have setup relays and used external switches on other ardupilot boards (pixhawk cube series) with success. The switches I used to use (turnigy receiver control switch) are not available. I was trying to use a 1 channel relay switch (, but it is not activating the relay, I can hear it trying to work, and the light changes on the relay board. I was trying to find the Navigator GPIO pins and came across this:

Does anyone have any ideas when relays will be available to work on the Navigator? Does anyone have any electronic switches they have used sucessfully with the Navigator? We have a couple extra ones of these I am going to try next ( Thanks!.


Hi @FairweatherIT -
The first relays you link require way to much drive current for the Navigator to drive! You should have better luck with the second link, as they are solid state. Ive used this option successfully with the Navigator! You’ll need to configure the control channel so it outputs 0 to 3.3V when triggered - see here for more details.

1 Like

Thanks Tony, I had used the other relays with a Raspberry pi on some other projects, so I had them in the shop. We are wiring up the second kind to see how that goes. Thanks for the link…


Greetings Tony,

Have you tried this using the rover firmware? The switch we have in the shop is exactly like the one you linked to. I tried to follow the instructions in the other thread, but the switch would not work on our Navigator running Rover Stable 4.2.3. There are not options for the relay_1_toggle in the Joystick settings. When I change the firmware to the latest sub version 4.1.1 I can follow the instructions with the exact same setup, and I can get the light to work. I pulled a Turnigy switch off of an old rover in the shop (pixhawk cube black) (before doing so checked to see that it worked), and connected this to the Navigator (back in Rover FW) and I could not get it to turn on lights either. Do you have any recommendations for getting this to work in the Rover firmware?



Hi @FairweatherIT - just jumping in with some clarifications :slight_smile:

I just checked the source code, and it seems that support for using the Navigator’s pins as relay outputs was only added in the latest stable (4.4.0). I’ve added that to the guide note.

ArduRover doesn’t use the same type of joystick control as ArduSub, so instead of using the autopilot’s internally registered button functions (via the MANUAL_CONTROL MAVLink message) it’s necessary to send DO_SET_RELAY commands.[1]

Cockpit does not yet have support for generic MAVLink commands, but it is planned. As far as I’m aware QGroundControl doesn’t support that kind of vehicle control, but from the ArduRover docs it seems that MissionPlanner does.

  1. ArduSub will likely end up moving in a similar direction (because in principle an autopilot shouldn’t need to know about or store the specifics of a given input method/device), but for now things are the way they are. ↩︎

1 Like

Thanks Eliot! Where do you download the Rover 4.4.0 for the navigator? In blue OS the version the highest stable is 4.2.3

Lower down we have a Beta 4.3 and a Dev version.

On the ArduPilot Firmware download page there is a version 4.4 but there is no version for the Navigator.

What version do you recommend to get relays working on the Navigator?

I really like the Toggle feature (relay_1_toggle) in sub so you do not need to use 2 buttons to turn on/off a switch (light, laser, siren). Is there anyway to make this available in the rover firmware, or put in a request for future versions?

Greetings, I checked this AM and it looks like the Rover 4.4.0 is availible to install on the Navigator in BlueOS. When I run the upgrade and reboot, the firmware says unknown and vehicle says unknown and I cannot connect to QGC or MP by default…

When I downgrade back to 4.2.3 the info shows correctly and I can connect to QGC and MP immediatly…

I tried some other tricks, like installing a different vehicle firmware (sub) and then back to Rover, but I get the above screen when installing Rover 4.4.0…Thanks.

Just a FYI, I picked up some of these pololu RC realys and they can be controlled by the Navigator, but requires the use of 2 buttons. One to turn on (pwm 1900) and one to turn off (pwm 900). I would love to get the momentary option that is available on the Sub firmware so only one button could be used.

1 Like