Qground control motor test fail

Hi I am just setting up my Blueboat and running my setup tests, I am attempting to test the motors in the qgroundcontrol gui and I keep getting this error while attempting to run a motor test in air

MAV_CMD_DO_MOTOR_TEST command failed

Any ideas what could be causing this issue?


Hi @Alex_Whitworth -
Have you connected to BlueOS and configured your vehicle yet? I would recommend navigating to vehicle setup, Configure, and loading the default (Blue Boat) parameters. You should also update BlueOS to the latest version, 1.2 beta 7, with pirate mode enabled this will appear in the BlueOS Version menu. Don’t forget to apply the bootstrap update if prompted!

I am having this same issue. I did try to load the parameters from BlueOS. Many of them worked, but 4 did not.

Even after updating the parameters that I could, QGroundControl still has issues arming the vehicle. It arms successfully, but then after a few seconds it disarms and I see an error message about the motor test failing. Any ideas how to fix this?

I think we found a workaround. We disabled all the “safety” features in QGroundControl and everything seems to be working fine now. So the only question is why was the motor test failing? The error message from QGroundControl does not shed much light on that.

Hi @timmarkhuff & @Alex_Whitworth -
Is the vehicle floating in water when you try the motor test? This test is supposed to run each of the motors, and automatically determine the correct direction they need to spin based on the reaction of the vehicle. If the vehicle is sitting on the bench, it will always fail!

Hi Tony, thanks for the help. I tried what you mentioned (loading the default parameters) and tried updating to the latest BlueOS but I wasn’t able to. I posted some additional issues I’m having here Vehicle setup/BlueOS issues