Motors refuse to spin

Hello all,
I have finally set out to do my first test but have failed to pass the motor test as instructed in the BlueBoat Software Setup.

A big red “Unable to determine motor count” warning comes up and motors refuse to spin.
I also tried to do motor testing within BlueOS, unfortunately without success either. Motors do not respond to the slider.

What am I doing wrong?
Any help would be greatly appreciated!

Have you tried testing the motor separately with a servo tester to see if it function normally? This will help you isolate the problem to either a defective motor or software configuration issue.

@rovtour thank you for your advice. Now that I learned about it, a servo tester should definitely be a part of my toolkit. Although I doubt two brand new motors/ESC’s have failed. I will be on a field trip for another day so I can’t test that. I am hoping it is a solvable software issue that I can sort out and possibly put the BB where it belongs (not on the bench)!

Problem solved. Did a clean install of BlueOS and did the motor test b4 I touch anything else and motors started to respond as expected! It looks like the BB is going to get wet! :grinning:

1 Like

I have located the source of the problem. I have connected a 4G modem (SIM7600G-H_4G_HAT). It is supposed to be a HAT but should be able to work independently via the USB port.
The moment I install the drivers, I lose control of the motors.
When connected to the PI’s USB port, it occupies the “/dev/ttyS0” serial port as opposed to “true USB” devices that occupy PI’s “/dev/ttyUSBX” ports.
I assume the the 4G modem is “clashing” with the Navigator since both are HATs and communicate through the serial port. Is there a solution to operate both at the same time, or I should replace it with a USB modem?

1 Like