Home        Store        Docs        Blog

Qground control / ardusub on raspberry pi 3 pxfmini motor not turning when armed

ardusub

(Romel Mendoza) #1

I have a RPI 3 with erlerobotics PXFMINI and with ardusub compiled for frambuesa OS of erlerobotics.
I can chose the frame and do xbox controller calibration.
I can do accel and magnetometer sensor calibration.
I can do arming and disarming the pxfmini however the motor is not rotating.
I can arm because I disabled the safety for battery or lets say all safety are disabled.
The battery voltage is also not showing even though I tried every sensor including the “others”.

You can see the attached photos and videos for your kind error reference.

I am using a emax bullet 30A esc with latest blheli-s firmware.
With 1500mah 4S battery.

Also the qgroundcontrol dashboard heading and horizon meter not working if you move the flight controller.

If you need other data for troubleshooting kindly let me know.

Looking forward for your kind advice soon.


(Patrick José Pereira) #2

Hi Rome,

Which version of QGC and ArduSub are you running ?
Have you configured the ArduPilot build system to build the binary for pxfmini ? That can explain why the IMU and others peripherals are not working.
I personally did some tests with pxfmini, using master branch of ArduSub, and at least I can read the board attitude.

Any further information of your setup and what you did to perform the build can help.


(Romel Mendoza) #3

Hi Patrick,
Thank you for looking on my case.
I used the erlerobotics procedure from another computer to build ardusub
http://docs.erlerobotics.com/erle_robots/projects/scuba/configuration


sudo apt-get install -y python-pip
sudo pip install future
sudo apt-get install -y gcc-arm-linux-gnueabihf
sudo apt-get install -y g+±arm-linux-gnueabihf
sudo apt-get install -y pkg-config-arm-linux-gnueabihf
git clone https://github.com/ardupilot/ardupilot
cd ardupilot/
git submodule update --init
./waf configure --board=pxfmini
./waf --targets bin/ardusub

Actually there are some errors so erlerobotics gave a working binary and I just transferred it in RPI3.


In their Frambuesa OS I installed ardusub by:
sudo apt-get install ardusub-erlebrain

and edited the script came to ardusub-erlebrain installation the apm.sh and replaced ArduSub.elf to the binary build by erlerobotics ardusub.
Then restarted and connected to qgroundcontrol V3.3.1.

other photo on the attached:


(Patrick José Pereira) #4

Hi Romel,

This steps are correct, you should be able to build with it.

It appears that this binary is a bit old, that’s why QGC is failing, besides that, you should use our version of QGC for better compatibility.

And about your photo, it appears that ArduSub is restarting and not being able to continue.
You should talk with erlerobotics about this issue, and I would also recommend to use the master branch of ArduSub to use it with pxfmini, or at least a newer version from erlerobotics.


(Romel Mendoza) #5

Hi Patrick,

Thanks…
I downloaded the QGC from the link you sent me and tried it out.
Still it was still the same.
I will check with erelrobotics about your above details.
Also I think the ardusub version V3.6-dev.


(Lander Usategui) #6

Hi @azkikr,

try to run the firmware manually and check if the firmware is not running as expected.

How are you running the firmware? Could you please share the content of /home/erle/apm.sh?

Regards,

@LanderU


(Jacob) #7

What is the value of sys_status.sensors_health, sensors_present in the Mavlink Inspector?


(Romel Mendoza) #8

Hi @LanderU ,
This is the output if the sudo ./ardusub (I cant kill the automatic ardusub running on process on background…

Please download my apm.sh here:
https://app.box.com/s/gitgrvwzuhhq4bho80zn90mn2r70n5yd


(Romel Mendoza) #9

Hi @jwalser

Please see attached for the mavlink inspector


(Jacob) #10

The one field I want to see is the only one that you have not expanded!


(Romel Mendoza) #11

Hi Jacob,
Sorry didnt realized that.
Kindly see attached


(Romel Mendoza) #12

Hi Guys,

Any progress for my case?

Thanks,

Romel


(Romel Mendoza) #13

@patrickelectric ,
Good day
Hi guys, any news?
Hope to received your advice soon.

Regards,

Romel


(Patrick José Pereira) #14

Hi @azkikr,

Sorry for taking so long to respond !
sensors_health is a bitmask and it appears that MAVLink inspector is using it as a normal number with scientific notation.
Can you open the Analyze tool from Widgets in QGC toolbar ? It’ll display the bitmask value without numeric notation.
After that, you just need to type bits in the Filter text entry.
Screenshot%20from%202018-05-02%2010-21-54

Besides that, can you send the content of /home/erle/APM/info/ardusub.log ?
It appears that the apm.sh script will redirect the output of ArduSub to this file.


(Romel Mendoza) #15


(Romel Mendoza) #16


(Romel Mendoza) #17

HI @patrickelectric ,

Good day and many thanks for your reply.

Please see above photo of the analyze1 and 2.
Also kindly download my ardusub.log from this link
https://app.box.com/s/k3wis1h7xhnrwc0xdnqeue56b73pf0d1

I hope this helps on troubleshooting.

Regards,

Romel


(Romel Mendoza) #18

@patrickelectric

With the filter ‘bits’