QGC map does not show ROV icon and wake

Hello. Thank you for all your help.

I am operating a BROV2 with a Waterlinked DVL50.

I have updated the QGC from your link, but now the DVL’s wake display is not working.


I installed as per the above link and was able to display the wake in previous versions, but now that I am on v4.2.3, not even the BROV2 icon is displayed.

Are there any precedents or solutions to these symptoms?

pixhawk 4.1.0(BETA)
companion 0.31
QGC v4.2.3

Hi @TakashiHisada, welcome to the forum :slight_smile:

I’m not certain what’s going on here, so I’ve asked about it internally and will get back to you.

In the meantime, does it work correctly with QGC v4.1.7? That’s our previous recommended version.

Hi Eliot, thanks for the reply.

I am pleased to report that I have since tried everything and successfully resolved the problem.

Cause No. 1: The DVL was installed in the opposite direction by 180°.

I had thought that “Orientation”- ‘Forward’ was valid, but it was under development.
This caused a lack of distance and no wake in our small pool.
After re-setting to the correct orientation, the wake was displayed.

Cause 2: When using the map tool in [Set Origin], the [Longitude] is in minus, but it does not work effectively in Japan.

The BROV2 vehicle icon was successfully displayed in Tokyo when the latitude and longitude were picked up from googlemap etc. and entered directly.

Minus [Longitude] notation and the map tool were valid in the vicinity of your company.

No matter how many times I told BROV2 about the ”set new origin” order,
I found BROV2 sitting in your outdoor pool in the US, and when I ordered it in your neighborhood to try it out,
it was successful, so I understood, oh, I see. :slight_smile:

By the way, to ensure that the result of “set new origin” is reflected, the battery must be removed and inserted each time.

Is there a smarter way to reflect this?

*I have also tried restarting from the companion software, but it is unstable, sometimes succeeding, sometimes not…

I spoke with the software team about this, and it’s possible it requires a value between -180 to 180, in which case the equivalent longitude would be 139.7611999512 - does that work?

I’ve raised an issue to confirm (and potentially fix) this issue in the BlueOS DVL package. The Companion software is no longer being developed or maintained, so if the issue is confirmed it will only be fixed for BlueOS.

ArduPilot firmwares currently only allows setting the origin once (which I’ve raised an issue about here). Until that gets changed, the least painful solution is restarting the autopilot, which in Companion can be handled by

  1. going to the web terminal,
  2. accessing mavproxy with
    screen -r mavproxy
  3. running the reboot command