Home        Store        Docs        Blog

Problem with running BlueROV


(Lukas) #1

Hi!

I have a problem. I started

roslaunch bluerov bluerov_r1.launch

at RPi2 and

roslaunch bluerov_apps teleop_f310.launch

at a computer. At RPi2 I got a result from Screenshot.png. Really interesting is a warning

[ WARN] [1459516580.638664256]: RC override not supported by this FCU!

I have a node/topic structure like at rosgraph.png. At the topic /joy and /mavros/rc/override value are changing when I change position of pad’s joystick.

At the ardupilot the red light is blinking which it is means that is not armed. I cannot arm the ardupilot even when I click arm button on f310.

My question is, what can I do wrong? I really would like to start my BlueROV robot.

 




(Josh) #2

Lukas,

What software do you have installed on the ardupilot? It must be our custom ArduSub software in order to work.

Josh


(Jacob) #3

The message about RC override can be ignored, ArduSub has support for it, but mavros is not aware of that at this point.
Make sure to follow the directions here. Namely, set the parameter ARMING_CHECK to disabled.


(Lukas) #4

I tried to upload ArduSub firmware following this instruction https://github.com/bluerobotics/ardusub/tree/master/ArduSub, but I saw the information

The following autopilots are not supported:

  • APM 1 through APM 2.6+
Actually I hace APM 2.6 which was recommend for BlueROV before January 2016. What should I do now? There is any possibility to upload ArduSub at APM 2.6?

(Jacob) #5

I modified ArduCopter for the APM 2.6 to run on the BlueROV. This has had much less testing than the current version and doesn’t have all of the features of the current ArduSub for Pixhawk. This code was basically just a proof of concept, and I don’t plan on developing it any further. The APM code is here. I think it will work with the current ROS package, if it doesn’t try this. Depth hold won’t work with the Blue Robotics depth sensor (without some minor modification to the code), this was tested with an MS5803. My suggestion is that you can try using this with your ROV, but you should get a PixHawk if you want support, features, and reliability.

-Jacob


(Lukas) #6

Thank you very much for the respond.

I cloned the repository, next I changed the branch to ROV-V1 and I entry to ArduCopter folder. Then I wanted to build by make and I did not see the option make apm2. Could you tell me how to upload a firmware to APM2.6? I am a newbie with ArduCopter device.


(Jacob) #7

Use branch ArduCopter-3.2.1, cd to the ArduCopter directory, and use ‘make upload’. More information here http://ardupilot.org/dev/docs/building_with_make.html.


(Lukas) #8

There is a problem because after ‘make upload’ I get

make: *** No rule to make target ArduCopter.cpp’, needed by/tmp/ArduCopter.build/ArduCopter.o’. Stop.

In this branch there are not a ArduCoper.cpp file in ArduCopter folder.


(Jacob) #9

I’m sorry for the delay. I haven’t built for the APM2.6 in months, so I don’t remember exactly the process. The APM uses an AVR microcontroller, and was structured in such a way that the Arduino IDE could build it. This means that many of the files end in .pde instead of .cpp, they are the same thing, and there is an ArduCopter.pde. I have been busy with work, and unable to boot into my Linux partition to see exactly what I did to build from the command line. When I get the chance, I will let you know.
-Jacob


(Jacob) #10

Use ‘make apm2’ to build or ‘make upload apm2’ to upload. I just pushed some minor changes that were left over on my computer, if it still doesn’t build, try make clean, or downloading it again. The most recent commit definitely builds successfully.
-Jacob


(Lukas) #11

Ok. I have programmed the apm2.6, but the problem is that the leds is not blinking and still using bluerov package I cannot turn on the thrusters. I arm the apm by clicking R2 button on the gamepad from Logitech. Do you have any idea why it don’t work?


(Jacob) #12

There could be several reasons, you would have to take a look at the source on both sides to find the problem. Try arming the device by clicking the button at the top of qgroundcontrol. If that works, try pushing each button on the gamepad one at a time, and see if the button mapping is not what you expect. If it doesn’t make sure the ARMING_CHECK parameter is disabled. You could also use the ros package I linked earlier, which is what I used when I was using apm. I used an xbox controller though, so you might have to remap the buttons.
-Jacob


(Lukas) #13

Which button at the top of qgroundcontrol should I click? I clicked the yellow one at the picture qgroundcontrol.png and nothing.

When the apm2.6 is armed, it should be the red diod turn on constant?

Where can I find ARMING_CHECK parameter? I was looking for in qgroundcontrol and I didn’t find.



(Jacob) #14

That is the button for viewing missions. Click where it says “disarmed” and it should ask you if you want to arm. To find the parameters, click the button with the gears, and select parameters from the menu that shows up. The documentation for qgroundcontrol is here: http://qgroundcontrol.org/start.
It appears that when armed, the red light should be constant. I don’t remember from personal experience. The documentation for the APM is here: http://ardupilot.org/copter/docs/common-apm-board-leds.html.
-Jacob


(Lukas) #15

Thank you very much Jacob for your help! Finally I use the firmware for apm2.6 from this site and I use bluerov-ros-pkg from this. Everything seems to be ok.


(Jacob) #16

That’s good to hear. Please be careful/cautious when using your ROV with this setup, and be prepared to deal with unexpected behavior. Keep in mind that it has not been tested by anyone but yourself!
-Jacob