Problem to connexion between the raspberry and the computer

I tried to build a drop down camera with raspberry card and navigator card but there isn’t connexion between the raspberry card and the computer. The cards start well when I put them with an alimentation. Have-you a solution to solve this problem ? Do you think that the electronic wiring is well realised ?

circuitDropDown.pdf (54.5 KB)


1 Like

You must install the Python 3 library and the MAF proxy and modify the baud number baud for you pixhawk

Hi @Eloi -
I don’t see a camera connected in your picture!
What does the BluArt connect to?
The Fathom-X tether interface is powered and connected to 2 wires for carrying data to the surface, but you haven’t plugged it into the Pi Ethernet port?

I’m afraid we have a bit of a language barrier, as I’m not sure what “The cards start well when I put them with an alimentation” means…

You should be able to reach the Raspberry Pi running BlueOS at or blueos.local…

Hi @tony-white,

Many thanks for your reply and apologies for the lack of clarity.

Our objective is to built a “smart” dropdown camera without any thruster but with lights, pitch and roll from the Navigator, pressure sensor, temperature sensor and camera. We purchased components individually as opposed to a full BlueROV2 electronics kit.

We are currently trying to make the Navigator+Pi4 stack work. Following some previous recommendations we are connecting the PC directly to the Pi4 using an ethernet cable and without any accessory.

When powering the stack, the Pi4 lights come ON (see photo) but there is not any beep. I read ⁠here that the first rising beeps are the number of cells detected from the batteries.

We have tested this with two SD cards on which BlueOS has been flashed, one that we made ourselves and one that the retailer sent to us separately from the Pi4+Navigator. These SD cards were flashed several months ago, we have tried to flash them with the latest BlueOS but are currently experiencing “locked” issues, probably due to lack of experience, as discussed in this post: SD card locked to download BlueOS version - Blue Robotics Software / BlueOS - Blue Robotics Community Forums

We have set the PC’s IP to, BlueOS does not reply on

Do we need to add any accessory (e.g. camera) for it to work?
Actually, where do the beeps physically comes from, the Navigator?
Could you please direct us to the next debugging step?

Thanks again for your support.

Louen and Eloi

Hi @Eloi -
Th beep referred to in other posts comes from the Motors and ESCs, this obviously won’t happen in your setup! It can take a couple minutes for the Pi to start up, before you can access it at
Sometimes a bad/damaged SD card adapter will appear as locked - I would try another if possible? Or another computer to flash the image?
BlueOS is accessed at, are you able to ping that address and get a response? Is your subnet mask configured to I would double check you configured the correct usb to ethernet adapter with the static IP if you’re still having issues. You may also want to plug a computer monitor into the Raspberry Pi to verify the unit is booting off of the SD Card without any errors.
Once you’re connected I would recommend updated BlueOS Version to 1.2 beta 7, and trying out the Cockpit beta 10 for light control and video recording! It is also possible to use QGroundControl for this, of course.
Best of luck!