No connection to blueos or navigator


I just replaced the pixHawk for a pi4 and navigator.
I have a bluerov2 heavy but after starting up and wait for 5 till 10 min after first start-up,I can’t get a connection between the rov and laptop.

Nav is having a blue flashing light

I connected the fathom interfaces with 2 wires directly to each other.

I can’t find a solution for this issue, can you help me?

Thanks Lennaert

Hi @Lennaert -
Congrats on the new hardware! Did you flash your SD card with BlueOS after installing?
Do you hear the motors give an initialization beep 2-3 minutes after you connect power?

I would recommend v1.2 beta 2 at the moment. Don’t forget to setup your ethernet adapter to give your computer the address of and a subnet mask of . You can than navigate to blueos.local, or, to finish the setup of your vehicle. You’ll select the heavy frame parameters, connect the Raspberry Pi to the internet, and configure as desired!

Hello Anthony,

thanks for you help
I did all you suggested before my post, but did and checked it all again.
That didn’t solved the problem.
The issue was that my ethernet switch didn’t received power.
so the fathom X didn’t connect to the navigator.
With power the issue was solved

Now running into a new issue, gyro doesn’t calibrate
running blueos v1.2 Beta 2 on my bluerov heavy
updated the DVL to the latest version
updated QGC to v4.3
Searching the forum for solutions but help is appriciated

Hi @Lennaert -
The Accelerometer and Compass calibration are conducted from QGround Control. Can you tell me which of them you’re having an issue with? The Gyro sensor does not require calibration.
The Accelerometer calibration requires the vehicle to be held motionless when in each of the orientations.
The Compass calibration requires the vehicle to be moved through all orientations and positions, while located as far from any ferrous metal or high-currents as possible - this can be difficult to accomplish on a large marine vessel.

Hi Anthony,

I still have issues with the sensors.
I can’t calibrate them.

I updated the software to:

QGC to 4.3.0
Running BlueOs 1.2.0 Beta 3
ArduPilot Stable 4.1.1
Waterlinked DVL v2.4.5

With Stable 4.1.1. I get the message “Failed to initialize Mavlink router”

When I Update to 4.1.2. Beta I don’t have this message

I tried to calibrate Accelerometer, I do get the 6 positions on my screen but then the proces stops.
I think I tried this about 20 times and only one time the proces started but it never finnished.

When I try to calibrate the Compas nothing happens.

I did received one message MAV_CMD (4242), don’t know if this has something to do with this. I don’t get this message every time

Hope you can give me some guidance in solving this issue.
I tried everything with the DVL turned on and off

thanks for your help

Hi @Lennaert -
It sounds like you don’t have a connection to the vehicle, but the problem could also be related to your QGC version. We recommend v4.2.8 not 4.3.0 as you are trying to use.
Once you’ve installed the correct version, can you verify the vehicle connects and responds to commands, like the camera tilt servo? If it does, I would expect a calibration to proceed normally.


QGC 4.2.8 did the trick.
Had to reboot 2 or 3 times but after that I could calibrate all the sensors

Now only have to connect the gripper, test if it’s watertight and go for a test run.

Thanks for your help


1 Like