Navigator not connecting to pc


I´m having some trouble trying to build my own ROV.

Around two months ago I swapped out the Pixhawk & Pi3 for the Navigator flight controller & Pi4.
Everything was working well for some time, but today I can´t seem to get a connection between my computer and the navigator. Turning on the device, neither QGC nor BlueOS will notice the device, and the last 3 (or so) beeps never come. What can be the problem when everything worked last week?
Teather cable is undamaged, measured 0Ohm.

It has been in the ocean, so I do not deny the possibility of corrosion. That being said I can’t see any signs of salt, and the leak-cushions are untouched.

I have successfully been running QGC 4.3, until today.

Hi @Erlingns95 -
We recommend QGC v4.2.8

From the sound of things, your Raspberry Pi may not be finishing the start up, and so you don’t hear the ESCs initialize with the motor beep. If you can’t ping, minutes after connecting power, then a problem with the Raspberry Pi is likely.
I’d recommend connecting a monitor to the Raspberry Pi 4 with the housing open, using an HDMI adapter. You should be able to monitor the boot process and see if there is an error this way. If you don’t have this available, you could try flashing your SD card with BlueOS. If you don’t have normal led and network led (on ethernet jack) blinks, the Raspberry Pi may be damaged…

You are correcting in saying it doesn’t finish the start up, and I don´t hear the ESCs motor beeps.
I´m also unable to reach

When directly linking my computer with the Pi using an HDMI, what program/app can I use to “monitor boot process”?

I have flashed the SD-card with a raspbian ardusub image using Raspberry Pi Images. It doesn´t seem the issue as the “ACT” Led on the Pi4 blinks irregularly, which it should if I´m not mistaken? It would give me some sort of morse-/blink code if the SD card was the problem?

Under the eth jack there are two leds lighting up. One orange/yellow on the bottom right side, and one green one on the bottom left. I´m not sure what “normal blinks” are, but the yellow one is constant and the green seems to blink quite irregularly.

I´ve also tried swapping out the Raspberry Pi4 with a new one, without advancement. The whole thing seems weird to me as it was working perfectly last week. What can have happened that resulted in the device not booting correctly?

Do you have any tips?

Hi @Erlingns95 -
No program is necessary - the monitor will display the boot process - text will scroll by if everything is working properly…

There are indeed blink codes that can indicate if the Raspberry Pi is bad.

It’s interesting that a new Pi didn’t resolve the issue. Can you confirm you flashed the SD card using Balena etcher?

Yes! Although I’m unsure about the image I’m supposed to flash onto it. I find it a bit confusing.

Could you tell me where i would find the correct image to use?

Hi @Erlingns95 -
If you flashed an invalid image, that would definitely keep the Raspberry Pi from booting!
Here is a direct link to 1.2 beta 8, you can find these under the BlueOS Github, Releases, and under the Assets dropdown, you want


Will get back to you after some testing.

Is it possible that my SD-card can be corrupt/broken? I’m trying to figure out why the problem originally occurred.