Pressure Sensor BAR30 "Depth Sensor Not Connected" (Navigator+RaspiberryPi4)


I need some very urgent help now, I hope you can help me again.

I have the following configuration, Bar30 sensor, connected to the I2C port of the Navigator that is with Ardupilot, and RaspiberryPI4 with BlueOS.

The problem is the following, everything works perfectly, only the pressure sensor that does not recognize, says that there is none connected.

I already tested with 3 different navigators, 2 sensors… I tested some other firmware versions available and nothing.

Hi @Igor,

I suspect this is a parameter issue. Can you

  1. make sure you’re using QGC 4.2.3
  2. open the Parameters page
  3. save your parameters to file (as a backup)
  4. reset default parameters (which will hopefully solve your issue)

Hi @EliotBR ,

I was keeping up with @Igor today, and we noted the mavlink message SCALED_PRESSURE2 wasn’t showing up. He tried both reinstall QGC and reflash BlueOs with no success. He tested two different BAR30 in 3 different Navigators, and none of them have worked.
Tomorrow morning we’ll try to reset default parameters, and we let you know if it works.

Most likely the issue is one of the following:

but if it’s a parameter issue then there may also be problems with other parameters, which is why I suggested resetting all to defaults :slight_smile:

Bar30 should definitely work with Navigator, and it would be very unusual for two sensors or three boards to be faulty in the same way.

Unfortunately it didn’t work. The BARO_EXT_BUS is showing as Unknown:6


That should be fine.

Can you please confirm that

  1. You’re using QGC 4.2.3
  2. The sensor is plugged in to an I2C 6 port
  3. The MS5611 (Bar30) sensor is detected as a barometer on the Summary page
    Screen Shot 2022-08-19 at 11.25.42 pm
  4. The parameters are set as I specified above (you probably shouldn’t need to change them, but it wouldn’t hurt to try)


This is how the sensor is plugged in (tried both):

And the sensor is not being detected:


And I set the parameters as specified.

We are going to a field job this weekend, and we’ll use the old setup with Pixhawk + old Bar30 version

I’ll try to test the sensors myself as soon as I get them.

Hi @EliotBR ,

I tried to run the Code Guide to Using the Bar30 with a Raspberry Pi directly on RPI4, but when i initialize the sensor I got:

>>> sensor.init()
PROM read error, CRC failed!

I expect that’s either from noisy communications (you may wish to try again, preferably making sure the cable is away from other electronics), or from a faulty/broken sensor. If that doesn’t help I’d recommend emailing support, in case they have more ideas, or they determine it’s best to replace the sensor.

A post was split to a new topic: Bar30 not detected by Pixhawk

Hi Elliot,

It’s been a long time since this thread was opened, but only now we could put together all the pieces in the workbench to test them. Unfortunately, one of the pressure sensors is not working at all, no matter the tests we do.

Hi @VMartini,

If a product you’ve bought from us is faulty / isn’t working then you’ll need to contact, to let them know

  • what’s going on
    • feel free to link to this post for some context
  • how the product has been stored and handled
  • any tests you’ve done, and
  • the order number (or at least rough order date)

If a product has not performed as specified and it hasn’t been mistreated then most likely you’ll get a replacement (or refund, as appropriate), and we’ll add it to our internal issue tracking to help reduce the likelihood of similar failures in future :slight_smile: