Bar30 not detected by Pixhawk

I’m having a similar issue as I no longer see the pressure (BAR30) sensor. It had been working earlier. I receive a calibration error on the barometer stating it can’t be found. I have the BlueROV ver 3 unit, QGC 4.2.3. I have tried the Parameter save and reset to default values with no success.

The Barometer is plugged in to a I2C port as shown below:

The BAR30 sensor in QGC shows up as:

The Barometer Parameter values are:

Is there a problem with what values I have here or has the sensor failed?

Do I need to provide more info?

Are there any simple tests that can be done directly on the Barometer to see if it is working?

Hi @bmartel,

I’ve moved your comment to its own post, because the other post was Navigator-specific :slight_smile:

The Pixhawk has an internal MS5611-based barometer that measures the air pressure, which is the one shown on your screen (connected via SPI1). The external MS5611 barometer from a Bar30 should show up as MS5611 (I2C1):

Screen Shot 2022-09-01 at 7.39.51 am

It should also show up as a non-zero BARO2_DEVID and BARO2_GND_PRESS.

In your case that’s not being displayed, so your Bar30 is not being detected. I’d recommend double checking the cable, making sure the connector is fully plugged in and that none of the wires are loose. If that doesn’t help your sensor (or Pixhawk I2C port) is damaged or faulty, so you should contact to discuss (include a link to this discussion, and your order number (or a rough order date) if possible).

Thanks Elliot
I did try with the power off unplugging the BAR30 sensor from the I2C port and plugging it in again, also checking the wires and there is no observable defects in it. Still no recognition of the sensor when I power up the ROV. I will contact support as you recommend.

1 Like

Hi Bob,
I have the same issue, do you manage to solve it?

1 Like

Having the same issue as the one commented on this post.

All firmware is updated, working with Bar30, parameters are set as other post comment it, but i dont see its connection on QGround.

All cables seems fine, it is getting power, and i2c pins are good.


Which post are you referring to? The original post this post was split from was for the Navigator, whereas this post is for the Pixhawk (which requires some different parameters).

BARO_EXT_BUS on a Pixhawk should be set to Bus1 (1).

1 Like

which version of the Pixhawk firmware are you using?

Maybe that could help. Just check that MS5611 is highlighted in BARO-PROBE_EXT as well ! Just had the trouble here and now it works fine.

1 Like