Pixhawk Boot Issue

Hi all, I used QGC to reflash the Pixhawk firmware during the heavy lifting retrofit. The QGC firmware update process appeared successful, printing “Upgrade Complete”. However, when I try to power up the ROV, the Pixhawk FMU and I/O B/E lights remain solid amber and QGC has no connection.


Are you able to connect with the ROV using

I believe that you can reboot the Pixhawk from that page.


The firmware is not running, try to flash it again. Note that reflashing the firmware is not a neccesary step in the first place for a heavy retrofit.

We slightly modified our frame definition, so we needed to re-flash. As I mentioned, QGC says it’s successful in flashing but the aforementioned B/E lights are solid amber and we are unable to talk to it. We have tried re-flashing with original firmware with the same result however.

Is there an SD card in the autopilot?


Can you make a video of the flash process and lights at boot?

Jacob, unfortunately I can’t take video in the lab. However, I can describe the FMU and I/O B/E lights.

  1. during flashing process: FMU is blinking amber and I/O is solid amber
  2. after flash power off and on: FMU- blinks amber for a few seconds and then goes solid amber. The I/O light blinks amber for a second and then goes solid amber.

Problem resolved: looks like there was an issue with the compiler not fully building so the binary was incomplete. Thanks for you help everyone.

wow. Thanks for letting us know.

Hi @asjb I encountered the same issue. Could you specify what was the problem and how to solve it please? Thanks!

Hi @lucasyu777, welcome to the forum :slight_smile:

When you’re finished flashing with QGC, is it detected correctly if you re-connect it to the computer, instead of connecting it straight to the vehicle? If it’s not detected as a vehicle I’d recommend trying to flash again.

Hi, thanks.

I solved the problem by connecting to a qgc on a windows machine. It turns out the problem was with my QGC in ubuntu system. When I open the software, the following message showed in the terminal:

qt.positioning.geoclue2: Unable to start the client: "org.freedesktop.DBus.Error.AccessDenied" "Agent rejected 'QGroundControl' for user '1000'. Please ensure that 'QGroundControl' has installed a valid QGroundControl.desktop file."

Have you had similar experiences before?


1 Like

Glad to hear it! :slight_smile:

Huh, interesting…

I haven’t, although I also don’t believe I’ve tried flashing from Ubuntu before. I’ll make a note to check that when I’ve next got some testing time.