Home        Store        Docs        Blog

Over-internet BlueROV control


(Xavier Riva-Pommarede) #1

Hello,

I am trying to control the BlueROV2 from a place far away through the internet. We have established a local network over the internet with Hamachi, everything seems to be in order on that part. But I can’t connect QGroundcontrol to the sub.

I have found the following topic which seems to be doing about the same thing, but there were not enough informations on it: Very remotely controlled!

So far, I have tried to modify the MAVproxy setup in the companion raspberry Pi to be able to connect to the required IP. If I understand correctly how this should be done, I have to modify the ~/companion/param/mavproxy.param.default file to open new connection possibilities. I have added the following line at the end of the file:

--out udpbcast:25.255.255.255:14550

With that line, every computer with an IP of the type 25.X.X.X should be able to connect to the sub via UDP on port 14550. (The IP given by the Hamachi network are all of the type 25.X.X.X with subnet mask 255.0.0.0)

Is there another configuration file or something that I should be aware of? Maybe in QGroundcontroll?

Thanks in advance for your help


(Patrick José Pereira) #2

Hi Xavier,

The mavproxy configuration can be done in http://192.168.2.2:2770/mavproxy, changing the last line to set the udpbcast.
You’ll need also to configure in http://192.168.2.2:2770/camera the video output ip address.

To allow a connection of the ROV between the internet, you need to make sure to open all necessary ports: 2770, 14550 and 5600. I don’t know about Hamachi, but you need to make sure that this ports are open and the connection between them are possible.


(Xavier Riva-Pommarede) #3

Hi,
I used to be able to connect on port 2770 to update the config, but I can’t anymore…Any idea why? port 8088 functions normally though.
If it can help to debug, I had to update the system to install Hamachi and I also was not able to connect in SSH so I had to reset the password. I don’t know if these could have any incidence?


(Jacob) #4

@Xavier.Riva-Pommared if you have modified the companion image, and installed additional networking services, then we cannot make any recommendation as to why things have broken.

You can check the source code of companion here and try to debug it.

The entry point is this script that is run at boot.


(Xavier Riva-Pommarede) #5

Hi,
We have decided to start from a fresh image and go step by step to check if something is not working.
Do you have a manual to explain all the elements of the setup interface? For instance, how am I to know that 192.168.2.2:2770 will give me configuration access? I found it by chance while browsing the forum but nowhere else. Also, how can I know by myself that mavproxy is accessed by 192.168.2.2:2770/mavproxy ?
In other words, do you have an advanced manual on software setup?


(Xavier Riva-Pommarede) #6

And another question I forgot to ask on the previous post: what is the default login/password to connect in ssh? I have tried pi/raspberry as this is the default on most raspberry distributions but it doesn’t work.


(Jacob) #7

See ardusub.com for more advanced information.

The default login is pi:companion.