Home        Store        Docs        Blog

"No Video" Error when running in QGC

(Madi Howard) #1

Hi all,

I am running the Ardusub setup with windows 7. I have successfully had everything running except for the camera. When I open QGC while the ROV is plugged in, I get zero camera feed. All motors are working properly. I have tried to run the following code to start up video process:

raspivid -n -fl -w 1280 -h 720 -b 10000000 -fps 30 -t 0 -o – | gst-launch-1.0 -v fdsrc ! h264parse ! rtph264pay config-interval=10 pt=96 ! udpsink host=<remote ip> port=5600

In return, I get the following error:

-bash: remote: No such file or directory
mmal: mmal_vc_component_enable: failed to enable component: ENOSPC
mmal: camera component couldn’t be enabled
mmal: main: Failed to create camera component
mmal: Failed to run camera app. Please check for firmware updates

Does anyone have any suggestions on how to solve this problem?


(Madi Howard) #2

I have also replaced and tried multiple Raspberry Pis and Pi cameras.

(TCIII) #3


Are you running a stable version of QGC or a daily build version?

Also, what version of ArduSub are you running. I believe that rc3 is the latest?



(Rusty) #4

Hi Madi,

You need to replace <remote ip> in that command with the IP address of the host computer that you are trying to send video to. If you’re using our setup instructions, that’s Make sure your Windows computer is set up with an IP address of to match. There are instructions here: http://ardusub.com/initial-setup/#windows

The rest of that error message indicates that the camera is not connected or set up properly. If you’re not using our Raspberry Pi image, you’ll have to enable the camera manually in the Raspberry Pi setup. Please see the Raspberry Pi camera instructions to learn how to do that.

Let me know if that helps.


(Madi Howard) #5

Rusty and TC,

I have successfully got some camera feed after updating QGC, but it has significant Lag and the video keeps cutting in and out. I have tried 3 different cameras and 2 different raspberry pis. They all have the same result. Do you have any suggestion on how to get a better result?

Thanks for all your help so far!

(Jacob) #6


It looks like you are using your own custom gstreamer pipeline on the raspberry pi to send the video. Do you mind sharing with us what your pipeline currently looks like, now that you have the video working?