Home        Store        Docs        Blog

No Thruster Bar in Qground


(Tom) #1

I just installed QCG on a new windows laptop. I went through the setup guide and when I made the connection to the ROV I had no Thruster Bar.

How do I get it back so I can configure the wired xbox controller?


(Daniel Heideman) #2

Tom,

Are you talking about the Motors tab on the Vehicle Setup page in QGroundControl (shown below)?

If you do not have the most recent version of ArduSub (3.5.3) installed on your ROV, this tab will not appear. See here for instructions on updating your ArduSub firmware.


(Tom) #3

I have it working on my MacBook just fine. Didn’t know why switching to the dark side with Windows based laptop would leave me with no connection.

R**egards,

Tom


(Daniel Heideman) #4

Are you having problems with the joystick tab showing up?


(Tom) #5

No, the thruster tab

R**egards,

Tom


(Jacob) #6

Tom, where are you at right now?

What works, what doesnt?

Have you followed the software setup instructions closely, including updating the software like @dheideman pointed out?


(Tom) #8

I have downloaded the QGC from your website link. at first I had gone right to QGCwebsite and installed that one.

So now when I start up I see QGC-blue robotics V6

then I ran the update ARDU and loaded the file from your docs.

it showed successful

then I ran QGC and had camera image from BlueROV but still no thruster tab


(Tom) #9

THANKS ALL!!!

Problem resolved. My laptop had corrupted the QGC file somehow. I uninstalled and reinstalled and all is working.

Ready for first dive with new laptop and BR Tether Spool and quick connect to ROV.


(Jacob) #10

Good to hear! Let us know if you need anything else.