No response from Ping1D

Trying to troubleshoot not being able to connect to a Ping1D. The same laptop detects 2 other ping1Ds fine over the serial and USB connection, so it shouldn’t be a software-related issue.

Just trying to get it to work directly via USB to the computer at this stage. I’ve tried 2 USB cables (one brand new). I’m getting a positive connection sound on Windows in both cases, and the UART is powered on (light) and constant blinking on the TX light. That’s as far as I’ve gotten, nothing is getting detected in Pingviewer. I’ve switched the TX and RX wires around but still nothing. Does anyone have other ideas?

Hi @Vincent,

The TX LED on the BLUART indicates the computer is sending data. If it’s not receiving anything back then there’s likely something wrong with the device, particularly given two others worked fine on the same connection.

I’d recommend you

  1. follow the device recovery instructions
  2. while the device is open, try to check continuity for each of the wires (by eye, or preferably with a multimeter)
  3. if those didn’t work/help, contact, link them to this thread, and let them know you’ve received a defective device - an order number/purchase date would be helpful