Home        Store        Docs        Blog

No connection from pixhawk to companion

The situation atm. is as following :
updated firmware on pixhawk v2 with newest stable ardusub and it wont connect. If i update with any of the other firmware for rover, plane etc. it works with no prob and i can start the calibration.

after the above steps i tried uninstalling gqc and formatted, fat32, the 8gb sdcard in the pixhawk and repeated the above but with the same result - no connection with the pixhawk. the main led doesnt blink at all with ardusub but behaves normal, blue constant, with the other firmware available.

read another thread with a person with same symptons but that thread died out before any real conclusion, hope you guys can help. thx in advance.

This still sounds like an sd card issue. I believe all vehicles stable versions but Sub work with no sd card.
Try flashing ArduSub Beta firmware through QGC, it works without the sd card. If it works, then it is probably an issue with the sd card or sd card connector.

Hi,

Tried installing the ardusub beta with no sdcard in :
After firmware update it´s waiting for connecting with vehicle and the following message comes up : “error on link px4 fmu v2 on COM4 (autoconnect). error connecting: could not create port. The specified file is not found

Also tried installing the stable ardusub with no sdcard :
Firmware installs as it should but after when it searches for connecting it asks for the sdcard - plugged it in and nothing else happens, no connection found.

Thx in advance for your time and help, much preciated!!

best regards

Hi Jimmi,

Ardupilot recently changed how the devices identify themselves (USB identifiers), I believe that was the issue there.

Try using another sd card, it looks like either it isn’t recognized or the sd card slot itself is damaged.

Hi Willian,

Thx alot for your reply - ill try and fetch a new SD card and try my luck

Best regards