No companion update button available


I am on the v0.0.16, no udpate button for version 17, is it normal?

Hi @Stevenlb, have you connected the ROV to the internet on the network page?

Yes, I did the Ardusub software update but after that and reboot the companion version is still 0.0.16.

I will check again tomorrow.

Hi Steven,

Did you refresh the browser page?

I made the same mistake wondering what was going on and ended up flashing it 3 times for no reason :slight_smile:


Yes I did. I tried several times, I am still stuck on PI V16…

I have got a problem with the underwater GPS as I do not get the depth reading from the ROV. Can it be linked to the fact that the PI did not update?

I have an inspection to do for a client ASAP, let me know please.

Hi Steven, it is not clear what your problem is.
Can you please provide a screenshot of the network page in the companion web interface?
Please also include some screenshots of the system page.


To begin using the Water Linked system again and get through your ASAP situation, you may also revert to using our previous edition of QGC (3.2.4-r6) here: Release v3.2.4-BlueRobotics-Rev6 · bluerobotics/qgroundcontrol · GitHub

Hi Jacob,

Below are some pictures:

I already tried to go back to the previous QGC version, it did not work when I was on site.

Hi Steven,

Try and connect the Raspberry Pi directly to your computer with a network cable to eliminate any communication issues when updating.


I also can not flash companion frame through Internet,can you give me the link which I can download and flash to SD card

@Stevenlb @MMMMK, please try the suggestions here about refreshing the page, and downloading a system log to help us debug and resolve the issue: Companion update button not appearing · Issue #251 · bluerobotics/companion · GitHub

webui.log (789.8 KB)
Hi Jacob,

Thanks for your reply, above is the log from the last time I tried to update the companion. Let me know.

I have the same issue, have internet coms, but no options to update. My last version is 15.

Hi Jacob,

Let me know tomorrow if you have time to have a look and what to do in order to realize the update. I have a waterlinked inspection on thursday so I need to be ready!

Hi @Stevenlb, I’ve found the problem in your log:

2019-04-24T12:49:38+0000 <log> index.js:776 () ping -c1 :  Error: Command failed: /bin/sh -c ping -c1
ping: unknown host

Based on this entry in the log, I would expect the ‘internet status’ on the network page to indicate ‘disconnected’. Can you confirm this?

@SHS Please provide a log as I instructed @Stevenlb.

No I confirm I was connected to internet. I did the ardusub update. Anyway, I could do the companion update directly on the sd card.


I solved this issue with downloading the software directly to the memory card and put it back again.

Now i have run i to another problem. When i run the pingwiever program the depth and heading stops in the OSD. Any idea what cause this issue?

I am offshore at the moment and not able to send Any logs from my system.

Svein H.

@SHS, please create a new topic regarding your new issue.

Hi Guys,

Button was missing after updating Pixhawk. Rebooted a couple of times with no difference. Unplugged battery for 5 mins and button showed up.

Wifi setup seems a bit buggy after updating as it is connected, bt does not discover any networks.


Viewing this thread in 2022. Still having a similar problem - software set up instructions indicate that the current companion software version is 0.0.31 (as @ 3 Dec 2021: However I’m getting no button on the system check page to update from the 0.0.17 that’s on there at the moment. Further, none of the various links to zip files for sideloading onto the Raspberry Pi seem to work. Can anyone point me to either a) a fix on the system page or b) a link to a file that I can sideload in? Cheers