Home        Store        Docs        Blog

Newton Gripper servo setup


(davo) #1

Installed newton gripper and would like some help to set-up the servo.
According to instructions it should operate on Servo03_Max.
Do you need to change something here or how do you go about setting up the controller.
I have a Xbox and would like for the gripper to operate on the 2 lower bumper controls?


(Jacob) #2

Please follow the software setup instructions here.
The two spring loaded triggers on the xbox controller can not be used for any function at the moment.


(davo) #3

Thank-you Jacob,
I’ll give it a try. Just one thing were is the Shift Control on the XBox 1 ?

Thanks

Dave


(Jacob) #4

The shift control can be assigned to any button. By default it is the center button.


(davo) #5

Still not getting this.
#5 Function = shift - disabled

What do I change this to?


(Jacob) #6

You don’t have to change it. It means that button 5 is assigned to have the shift function. Button 5 will work like the shift key on your keyboard to alter the function of the other buttons when they are pushed while holding shift down.


(davo) #7

I tried that and an XBox bar appears on screen and says I have lost manual control


(davo) #8

The #5 function doesn’t light when I engage it.


(Jacob) #9

See here: JOYSTICK function


(Kaos) #10

@spudder
I run a wireless xbox one controller and have setup the x button as the shift button. The gripper uses the top shoulder buttons and i hold the x button down to move camera up n down with same shoulder buttons. Works well. Hope this helps


(davo) #11

Thks, I’ll give it a try.


(davo) #12

Thanks very much for your help and input Jacob.
I switched to another joystick function and it is now working.

Just one more question; the gripper is either fully open or closed, there is no stopping at any increment?

Again thank-you as you guys are a great support - hats off to the team.

Spudder


(k.deboer) #13

Spudder,
Mine did the same thing until I changed the joystick buttons to this:

servo_X_max_momentary (open while pressed)
servo_X_min_momentary (close while pressed)

I had them set to Increment/Decrement before.

Ken


(Doyle) #14

Where is servo_X_max_momentary found?
QGroundCOntrolv3.3.2 Joystick?
thanks


(Doyle) #15

Ok…did some trial and error.
i have a Logitech f301.
the shift key (logo button) does not respond so i set button 0 (Y) as the shift key.
In QGroundControl 3.3.2, i don’t have servo_3_min_momentary or servo_3_max_momentary.
i have servo_3_dec,servo_3_inc,servo_3_max,servo_3_min
which version will give me _momentary? the Gripper only has two states…fully open or close.
thanks!
Doyle


(Kevin) #16

@maleche1 The base version of QGC isn’t supported right now, you will have to use our most recent QGC v3.2.4-BlueRobotics-Rev6 which should also be the version of QGC linked all throughout our documentation.

Make sure you also update the ROv firmware to ArduSub 3.5.3 or you won’t see any of the momentary actions.