New user- QGC disconnect


We’re just setting up our ROV and software on the laptop. The laptop was talking to QGC no problem for around an hour and then all of a sudden QGC has disconnected from the ROV and we cannot get the two linked up again. We’ve tried the usual - rebooted QGC, the laptop, tried all cable connections. It seems od that it would be working fine one minute and then stop working the next. Can anyone help please? Also, when you want to ‘reboot’ the ROV, is the only way to do that to take the battery out?



Hi @YWT, welcome to the forum :slight_smile:

Sorry to hear you’re having connectivity issues.

A sudden disconnect is likely to be some kind of hardware issue, assuming you didn’t change the software or network configuration just before it stopped working.

I’m off work now, so won’t be able to respond again until tomorrow at least, but I’d recommend that you check

  • is there still sufficient battery?
  • does rebooting the ROV help?
  • have you lost the video stream, vehicle telemetry, or both?
    • if one is working then your network UDP access is fine, in which case there’s an issue with the device and/or cable for the other one
  • are you able to access the BlueOS web interface?
    • if so, are the autopilot and camera both showing up as detected in the web interface?
      • check the General and Video pages
    • if not your Raspberry Pi SD card may be corrupted, in which case maybe try flashing BlueOS onto the Raspberry Pi SD card, and/or try a fresh SD card
      • if that doesn’t help, there may be some issue with your Raspberry Pi, especially if its red power LED and green status LED aren’t doing anything when powered on

If you aren’t able to figure out what’s going on I’d recommend contacting to get some help, and sort out a replacement part or refund as relevant. When submitting a support email please provide the context of your issue (a link to this forum thread would likely help), along with what you’ve tried so far, and your order number (or at least a rough order date).

No, it should also be possible to reboot the autopilot and/or the onboard computer from the web interface, assuming the onboard computer is actually running (otherwise the web interface won’t be available).

Hi Eliot,

Thanks for your speedy reply. I shall go through each of your suggestions in turn. No we didnt make any changes to software prior to the disconnect happening. We were in the middle of calibrating the sensors. We’ve lost video stream and vehicle telemetry - the ‘link active’ light has gone out on the Fathom X interface. I’ll try the suggestions and report back. Thanks very much, Bex

1 Like

Not sure if this has been resolved yet, but by that description there’s likely been some kind of hardware issue - be that insufficient power, a damaged connection, or a fried board. If checking the cables and plugging in a charged battery doesn’t restore the connection between the Fathom-Xs then you’ll likely need to contact the support email.