Home        Store        Learn        Blog

Need help setting up QGroundControl for Qt or Visual Studio

I tried to set up QGroundControl in Qt creator and Visual Studio but with both application I got an error that I do not know how to solve.

The problem I got with Qt creator is that I cant use the design tool and because I don’t know how to use the 5.12.6 version of Qt in the creator, I can’t use the MavLink commands.

With Visual Studio when I try to build the code I get an error with cmake, where there is a library non static.

Hi @Nigel, welcome to the forum :slight_smile:

There’s a recent and very similar question to this here which is likely relevant. In particular,

If that and the other comments in that topic don’t solve the issue, please follow up with what you’ve tried so far and the error message(s) you’re receiving, so we can try to help figure out what’s not set up correctly :slight_smile:

Yes I am following the getting started instructions and updated the submodules after cloning. tried building it in visual studio 2017 and 2019 with the Qt extension. In the extension I linked the 5.12.6 qmake.exe to set the version but it kept giving an error that asked for the 5.15.0, so I added a link to that version as well.

But now I got this error:

Severity	Code	Description	Project	File	Line	Suppression State
Error		CMake Error: The inter-target dependency graph contains the following strongly connected component (cycle):
  "libevents_parser" of type SHARED_LIBRARY
    depends on "comm" (weak)
    depends on "qgc" (weak)
    depends on "ADSB" (weak)
    depends on "Airmap" (weak)
    ...
  "VehicleSetup" of type SHARED_LIBRARY
    depends on "compression" (weak)
    depends on "qgc" (weak)
    depends on "ADSB" (weak)
At least one of these targets is not a STATIC_LIBRARY.  Cyclic dependencies are allowed only among static libraries.

Are you able to try building with Qt Creator instead?

I don’t believe that should be necessary, but 5.15.0 was mentioned in the other thread as well - I’ll try to make some time tomorrow to set up Windows and go through the build process to see if I find any issues with it (last time I needed to was about a year ago at a different company, although from memory it doesn’t look like the process has changed).

@Nigel Following up on this, I ended up discussing and debugging this in more depth with @Mina. Would you mind following the resulting instructions here and seeing if you still have build issues?

It worked!! Thank you very much.

1 Like