MyGCS:255 error


We have been using navigator and customed Ardusub 4.1.0 for a while smoothly but recently, we have encountered some weird problem and not sure where it could be coming from.

A little bit of insight about our version, we have made some alterations to a custom frame vector map in AP_motors and AP_battmonitor but they all work fine. However, last week, we tried to implement a function in Joystick.cpp (turn on pitch/roll function when pressing a button and return to movement control when release it).

We were able to compile the firmware, flashed it to our navigator and ran it on QGC normally. All functions seem fine but MYGCC:255 errors were constantly popping up between 30s to 1min. We then flashed our old firmware into the Navigator, but this problem still exists. After a while of changing between different HCU, this problem seems to stop popping up for the rest of the day but started the same errors the next day.

It would be awesome if you guys could help us solving this problem before we installed it into our ROV. Thank you so much

PS: we power the Navigator via PC’s USB cable. We are also using ethernet cable plugged directly to PC for comms and were using LeoBodnar boards for our HCUs.

Hi @qnguyen,

I asked about this internally and was told it’s a known issue that doesn’t seem to affect functionality, so it hasn’t been looked into in much depth yet.

From what I could gather it’s likely a heartbeat timing or connectivity issue. I was told it might help to have the vehicle and topside computer disconnected from wifi.

Hi Eliot,

Thank you for letting me know, we will try again without connecting to wifi (I was also using VPN) (FYI, when the error happened, it automatically disarms the vehicle) and let you know if it still persists. We have tried multiple firmwares including factory (4.1.0 beta) on different Nav yesterday but returns same result so we thought it may have been transmission/ QGC issue.

Also, when we were controlling our custom manufactured ROV, it would occasionally have that issue as well and disarmed the vehicle immediately (sometimes it happens once per whole day of working).

Hmm, maybe check (and, if relevant, change) the FS_GCS_ENABLE parameter?

It likely is some form of communication issue, but it might be an issue with occasional lost packets, which could be hard to avoid without just reducing the network traffic and noise (e.g. by disconnecting and/or shielding from networks you’re not actively using).