Motor problem of BlueROV2 Heavy Upgrade

i think we bought the bluerov2 last year and this is our first time to connect the extra bluerov2
heavy set, so we connected all cables and, just checked the motors are working but,
as you know, there are 8 motors in the set.

but when i tried to look the motor is working, the 1~7 is working and remained motor is not working.
so i tried to check the esc and motor is wrong with the arduino code in the site, but motor was okey.

is there any solution for this? and i wanted to know how to use my xbox controller.
is there any one who knows about that?

Hi Lee,

Do you mean the ESC was having issues? The easiest way to diagnose motor/ESC problems is just to switch the wires from the ‘problem’ motor and see if it works with a known working ESC from another motor. You can reflash ESCs but if you have a spare ESC lying around that’s usually a much simpler fix.

Once you paired the Xbox controller with your laptop, it should immediately come up in Qgroundcontrol.

1 Like

i have check through the arduino code to check the motor and esc is working
but i’ve checked that those are not the problem, because of now we do not have a spare escs.
so we can’t change them right away, is there any other reason that you think, is going to happen with not moving paricular motor? as you know in this heavy set it has 8 motors but 7 is working with the qgroundcontrol but remain one is not working.

so the procedure that i took was this,

  1. first check the motor is wokrking(worked)
  2. and then reconnected and do the same thing with motor test in qgroundcontrol
  3. in qgroundcontrol(it was not working)
  4. so i switched to other + or - section to find out the solution, cause it can be the pole problem.
    but i was not working either.
  5. after that i got missed with in this ㅠ

is there any problem that you think can help me?

Also check the ESC is arming and connected properly, not just at the motor end but also the power and signal wires. You might have not connected the signal wire to the correct port on the pixhawk.

1 Like

thanks for replying. i found the solution for this problem
the problem was pinkhawk module, the 7 pin was squeezed so the signal can’t send to the motor.
anyway. thank you very much for helping me.

have a nice day!

1 Like