MicroNav USBL GPS on a BR2

Hi
I have tried to find that information , do you mean the QGC program ? if so its the latest version V4.0.5 and sorry i am not sure where i find/check where SERIAL0_PROTOCOL set to Mavlink2 is correct , its my first time i am having this sort of problem and never had to check all these things so i do not know my way around the program, raspberry PI or any of the operating system
thanks for any guidance

This solution form Blue Robotics is a great platform, and us BR users are a great community that supports each other.

With the ROV on, and connected, open a browser in the QGC laptop. Go to 192.168.2.2:2770. Click on the System tab. Scroll down to the ArduSub Companion Computer Setup section. That will tell you the version installed in the Raspberry Pi. It may tell you there is a newer version available to install.

Then is QGC, open the Settings. In the Parameters section, look for the search bar, and enter SERIAL0_PROTOCOL.

Hopefully these steps will get us closer.

Hello
yes this BR platform is great and very helpful people on it , like yourself and Boko who is willing to spend time and assist people like me

software is 0.0.17
Serialo_protocol is Mavlink1

thanks

You will need to update the software to the latest. There is a “Stable” button in the ArduSub Companion Computer Setup section. Make sure the ROV has a good Wifi connection. You can make sure it is connected by clicking on the Network tab at 192.168.2.2:2770.

Also, change the SERIAL0_PROTOCOL to MavLink 2

I think we’re getting closer…

@Mac1,
I want to mention, the Companion update takes a bit of time, Be patient. Watch the window for progress

installed/updated as requested
still no transponder reading on control panel
should i re boot pixhawk ?
should i be going through the NMEA Router ?
what settings on the QGC should the auto connect to the following devices be set to ?


You will still need to run the NMEA router on your QGC laptop, forwarding to 192.168.2.2:27000

Now that you’ve updated the Raspberry Pi, please go back to the Terminal window, 192.168.2.2:8088. Run the screen command and see if it’s happy.

Oh,

You’d be best to power cycle the ROV now that you’ve done all that.

ran ping commands on 192.168.2.2 & 1
all happy and good replies

powered ROV off and on again (disconnected )
NMEA router working good
auto connect set to UDP and listen on 27000

transponder position still showing
0000000

Go back into the QGC Settings Parameters section;

Search: GPS_TYPE

I believe it should be set to: NMEA

set to NMEA now but no difference to transponder reading 000000

also on the Map screen it has always said “No GPS lock for the Vehicle”
i do not suppose that message gives you any extra info to work with as its more to do with the lat and long 00000 readings not changing

Log into the Raspberry Pi Terminal window, 192.168.2.2:8088. Run the ‘screen’ command and see if it’s happy.

I typed in screen and then enter and got a copy right result ?

is that correct ? for a happy result ?

Type this command in the terminal window:

screen -r nmearx

position seems to be going into the PI, am i correct ?

Yes,
Data is getting to the Pi,. But it looks like there’s an issue with the NMEA stream
Is it in this format:
$GPRMC,hhmmss.ss,A,xxxx.xxxx,a,yyyyy.yyyy,a,x.x,x.x,ddmmyy,x.x,a*hh

The error in the terminal indicates a checksum issue

i re ran it again and got this

I think that’s a Linux thing. My weak point. I think if you hit ctrl-x and exit, then open the window again. It should work.

???

the first screen -r nmearx was with $GPGGA

and then i changed it to $GPRMC to see if it made any difference ,
image

i was advised to use the GPGGA data format to send the transponder position by tritech