Home        Store        Learn        Blog

Leo Bodnar micro BBI

Hi all,
Am trying to use the Bodnar micro board where only a few button pushes are required. The instructions for use suggest that it is plug and play, and it does show up in Windows devices, however it won’t show up in QGC. Has anyone that has used the full featured Bodnar boards advise if any settings needed to be changed to enable the board in QGC?

Thanks!

Marcus,
I’s been a while, but when I started using the Bodnar board, there was a dropdown menu where you can choose the input device in the Joystick setup section of QGC. I’ll take a look in the morning, and see if I can take a screen shot.

thanks, but when I plug it in, it’s not recognized at all in QGC (i.e there is no joystick tab), and the gamepad icon is red and says not connected, not enabled. Unless do you mean in the general settings?

Here is what I see.

Try plugging in both the gamepad controller as well as the Bodnar. Then maybe you’ll get the Joystick tab.

Thanks Ken, no luck unfortunately. With a Logitech plugged in I have the drop down, but only the Logitech is shown. I’ve emailed Bodnar to see if they have any ideas.
Cheers

Apparently (according to Leo Bodnar support) there should be no difference in the way the mini connects to QGC vs the BU0836X, but something isn’t right. Is that the model you are using @k-deboer ?

@williangalvani et al do you know whether there has been support added for specific models of these boards?

Cheers

Yes, That is the board I use.

1 Like

Ok thanks. Very strange. The board is recognised in Windows, and works in @paul-unterweiser sim program, but not QGC…Have tried on multiple machines, so I don’t think its a PC issue

Hi Marcus, I remember having the same issue before because I didn’t plug all the axis, qgc wouldn’t pick it up.

Thanks @etienne , I was wondering that, because I only have a few buttons connected. So I’m wondering what QGC is looking for and what the minimum component to connect would be? A hall effect joystick?
Cheers

Just put a trim pot on each 4 axis so it’s a “valid joystick” for piloting… Let me know if it solves it.

Thanks @etienne , the mini only has 1 analog input, and connecting a pot to that doesn’t resolve the issue. I’m waiting on a new delivery of the BU0836A which has more analog inputs, so hopefully that will work. Will update once tested

Thanks @etienne, this worked for the BUO836A. I connected one trim pot, and bridged 4x sets of VCC, signal and GND, and the board is recognised in QGC. It must run a startup check, because once it is connected, the pot can be removed and the joystick remains connected. Cheers!

Yeah, a major pain in the … I haven’t used this joystick control board in a while since I build my own now. That said, I did remember pulling my hair out trying to figure out why it didn’t work in QGC… :slight_smile:

So with the BUO836A, using the config software, if you uncheck auto detection of analog inputs, the board is recognised in QGC without any other components needed to be connected! This option is not available with the mini version, so I think these boards may not be suitable.

2 Likes