Home        Store        Learn        Blog

Leak Detector False Alarm

Hi! The leak sensor worked one time but now it always reports a leak (the red light is always on) even when no probes are connected to the circuit board. All the settings are correct and it worked before. Thanks in advance for your help!

Hi @l.faye,

The leak sensing is by default active low, so if the leak detector isn’t plugged in to the port it will report a leak. Is there any chance you’ve unplugged the detector from the Pixhawk, or plugged it in to a different port than the one it’s assigned to? By default it should be in Aux 6 :slight_smile:

I just checked, and it’s plugged into Aux 6. I’ve also tried restarting the ArduSub multiple times, but it still gives me the same error. Could it be possible that I got some water into the board, or is it just a softward/hardware issue?

If it was working before but is now giving a leak warning then presumably one of the probes is either wet, or has been squished and has ended up short-circuiting.

Can you try disconnecting each probe from the board and see if one of them is causing the issue? :slight_smile:

I’ve tried each of the probes, they’re all fine, but when I disconnected all the probes, the board’s light was still on and it gave me the leak detected warning.