Home        Store        Docs        Blog

Is ArduSub compatible with Cube Orange?

I have an ArduSub system on the bench that consists of a Pi B companion linked via network cable to Windows 10 desktop PC with static IP on 192.168.2.1. I have both PixHawk 4 and Cube Orange (on mini carrier) available.

The PixHawk4 works fine, the Cube Orange does not.

The issue is that when checking the companion web interface, the Cube Orange is listed as a serial device in “Detected Devices” but no communication with QGroundControl takes place. Under “ArduSub Version” is the text “not found”.

When using the PixHawk4, I immediately get communication with QGC.

The ArduSub.com troubleshooting guide is excellent, and I have worked my way though it but no luck unfortunately.

Here is a quick summary:

Network configuration is verified. Using ping to the companion computer works fine. The web interface download and upload tests are both strong at around 95Mbps using a 4m RJ45 cable.

Firewall exceptions set up for both UDP ports (also tried disabling the firewall).

PC, companion and autopilot systems all rebooted numerous times in various sequences.

All cabling swapped out. 3 differentRaspberry Pi units tried.

QGC set to autoconnect to UDP and USB

On the system page there is a correct entry under serial devices for PixHawk4 and for Cube Orange, depending on which device is connected.

When using the terminal page to check MavProxy with the screen command, the PixHawk4 gives a sensible response but the Cube Orange gives only a blank terminal screen.

Resetting MavProxy options has no effect

I am unable to upload firmware via the web interface on either device. Both fail with “waiting for bootloader”. Both devices update with no issues when using QGC with a direct USB connection.

QGC, companion and ArduSub are all the latest ‘stable’ code versions

Have to say I am running out of ideas here. Would appreciate any help…

C

Hi @ColinC

We have some code in Companion that right now is specific to Pixhawks.
To get communication working, change http://192.168.2.2:2770/mavproxy so it points to the correct TTY device for your Cube Orange instead ot /dev/autopilot.

Thanks Willian!

I was not too sure where to point it for the Cube Orange. I read out the connected USB devices on my system which reported Cube Orange on ttyACM0 and ttyACM1. I also found a reference online that the Cube uses ttyS0 or ttyAMA0.

Anyway, I tried all of these possibilities by changing the Mavproxy terminal entry such as…

–master=/dev/ttyACM0,115200

…but no luck.

I am hitting “Restart MavProxy” on each attempt

I have a feeling I am doing something dumb :slight_smile:

C

Open the terminal and type ls /dev/tty*and paste it here.
Do you have any other serial device connected? like the ping1d or ping360?

Hi Willian

Thank you for your help so far.

Here is the tty list:

pi@raspberrypi:~ ls /dev/tty* /dev/tty /dev/tty15 /dev/tty22 /dev/tty3 /dev/tty37 /dev/tty44 /dev/tty51 /dev/tty59 /dev/tty9 /dev/tty0 /dev/tty16 /dev/tty23 /dev/tty30 /dev/tty38 /dev/tty45 /dev/tty52 /dev/tty6 /dev/ttyACM0 /dev/tty1 /dev/tty17 /dev/tty24 /dev/tty31 /dev/tty39 /dev/tty46 /dev/tty53 /dev/tty60 /dev/ttyACM1 /dev/tty10 /dev/tty18 /dev/tty25 /dev/tty32 /dev/tty4 /dev/tty47 /dev/tty54 /dev/tty61 /dev/ttyAMA0 /dev/tty11 /dev/tty19 /dev/tty26 /dev/tty33 /dev/tty40 /dev/tty48 /dev/tty55 /dev/tty62 /dev/ttyprintk /dev/tty12 /dev/tty2 /dev/tty27 /dev/tty34 /dev/tty41 /dev/tty49 /dev/tty56 /dev/tty63 /dev/ttyS0 /dev/tty13 /dev/tty20 /dev/tty28 /dev/tty35 /dev/tty42 /dev/tty5 /dev/tty57 /dev/tty7 /dev/tty14 /dev/tty21 /dev/tty29 /dev/tty36 /dev/tty43 /dev/tty50 /dev/tty58 /dev/tty8 pi@raspberrypi:~

There are no ohter serial devices connected at this time. This is a fresh install of the ArduSub code on a card formatted in FAT32

C

Hi, I think it should really be either /dev/ttyACM0 or /dev/ttyACM1

Try connecting directly to QGC and checking the baudrate

Thanks again for your time Willian.

I have connected directly and the baud rate on Serial0 is definitely 115K. I tried again with ACM0 and ACM1 (also using 57600) but the issue remains.

The Cube Orange is also now misbehaving when connected to QGC. I am seeing the following messages after a direct USB connection is made:

When that is closed, I also get this:

Following that procedure above does not make any difference.

The Cube Orange however is working properly with my bench setup. I am able to arm and disarm the system, run 3 thrusters and control LEDs (PWM) and lasers (Relay).

If I load different firmware onto the Cube (ArduRover), the issue disappears.

I do not see the issue on the PixHawk4.

Any further thoughts would be really appreciated…

C

Hi, the first warning ins benign, it happens because the power module is not set up yet.
The second one is more concerning. it looks like the autopilot stops responding, which would explain why the companion is not recognizing it.

Unfortunately I don’t have a Cube Orange to experiment with, so it is harder to help.

Can you get logs from the sd card?

Hi Willian

Hopefully I have done this correctly. I have tried to make it as simple as possible by connecting the Cube Orange directly to USB and waiting only until the message appears saying that the vehicle is not communicating.

I have attached the log from QGC which was taken by setting the system to “Save logs even if the vehicle was not armed”.

I have also attached the log from the SD card in the Cube Orange. This was taken after setting the LOG_DISARMED parameter to ENABLED.

Hopefully there might be some clue in there - thanks again for your help…

00000001.BIN (1.1 MB)
2020-05-22 09-17-49.tlog (3.1 MB)

C

I suspect it could be a hardware problem, have you tried a different cable? The log shows that ardusub is running but lost connection to the GCS.
Is Rover still working ok?

I have used many different cables but they are all things I had lying around. I have ordered some new ones that are high quality.

Rover was working Ok yesterday but I just tried it again and it is now throwing up the same error.

I also installed the normal QGC version as I know there are some differences with the ArduSub one.

All give the same error.

I will try again with the new cables when they arrive but i think I maybe have a faulty Cube here?

C

Yes, it sounds like a hardware issue in the serial communication.