Home        Store        Learn        Blog

Using Different Pixhawk Models with QGroundControl on Mac

Hi! I wanted to ask if there are any other Pixhawk models that are QGC compatible, since I think Pixhawk 1s aren’t being manufactured anymore. I’ve tried a Pixhawk 4 and Pixhawk 2.4.8, but none of them have been able to connect to either a Mac or Windows computer.

Does anyone know where to find Pixhawk 1s, and if there are any other options for Pixhawks that are also QGC compatible?

Thanks so much!

Edit: I read some articles confirming that Pixhawk 4 should work, but I’m not exactly sure what needs to be changed for the Pixhawk 4 to be ArduSub compatible.

Hi @l.faye,

That’s correct - they’re past end of life so are generally only sold in pre-packaged kits and the like that require them. We’re working hard on a replacement, which I believe should become available in the next few months.

That’s unexpected - how are you connecting them? As far as I’m aware all Pixhawk versions should be QGC compatible (on any OS) - you’re more likely to run into issues with ArduSub not fully supporting them because it’s been primarily designed around Pixhawk1. As far as I’m aware you should still be able to flash them with ArduSub, but there may be some issues/missing features (e.g. see this post).

1 Like

Oh okay, gotcha, thank you!

I’ve just simply plugged it into the computer through a USB to micro USB connector. Should I be connecting it through the Raspberry Pi or some other method?

That should be fine, although you’ll need to make sure your QGC is set up to AutoConnect to Pixhawk devices,


and if it’s not working it might be worth trying a different cable (some cables aren’t great, and I believe some are only intended for powering instead of also working for data transfer)

If you’ve got a companion computer set up that should also work, although it’s then a “UDP” connection from that to your top computer :slight_smile:

1 Like

Oh I didn’t even notice that, thank you so much!

1 Like

No problem - we’re here to help :slight_smile:
Not much point making and selling awesome products if they’re not supported well enough for people to use them.

Did that solve this issue? If so please mark that comment as the ‘Solution’ :slight_smile:

1 Like

Unfortunately I don’t think so (the Pixhawk’s green lights are solid and the blue ones are flashing if that means anything). QGroundControl says it’s still waiting for a vehicle connection – do I need to connect the Raspberry Pi as well?


The PX4 docs seem to have decent Pixhawk 4 documentation, including for the status LEDs. Blue flashing for the “Activity” (ACT) light seems to mean the bootloader is receiving data. At a guess I’d suggest going to the “Firmware” tab in QGC (click the gears at the top left) and seeing if it appears there so that you can specify the firmware you want to flash.

You could do, although QGC can only flash with direct connections so doing so would require a different approach. I’m not sure if our companion web interface is set up to flash boards other than the Pixhawk 1, although it wouldn’t hurt to try plugging it in and seeing what comes up :slight_smile:

We have instructions here for both approaches, although they’re tailored to the Pixhawk 1 so you’d need to determine the equivalent buttons assuming they exist (definitely should for QGC, might also for companion).

1 Like

Oh okay, got it! I’ll look through the documentation, thanks so much.

Here it’s saying that I need to plug in the device to start the firmware upgrade, so I think that means the computer isn’t recognizing the Pixhawk.

I tried this as well, and the Serial Devices tab says none, as attached.

Just tried a different cable and it works!!! Thanks so much :)))))

1 Like