Gps g2/integration kit/simrad hs60 via actisense ngw conversion gateway

I’ve restarted the waterlinked driver -


however no gps lock shown QGC - the waterlinked gui position is stable and all green.

The previous Waterlinked GPS explorer kit integrated automatically - I can’t see why the new GPS2 won’t?

Regarding driver restart in companion to get automatic integration, there is a problem with Waterlinked Gen 2.
Temporary solution is to reset the driver in companion GUI after every restart of system.

I tried that - as above - doesn’t fix the problem.

Link to other post of how to check what NMEA companion is getting by logging into Raspberry/Companion:


If it shows “Scanning for Waterlinked Underwater GPS”, it means that the ROV is unable to find the underwater gps in the network. are they in the same network? How are things wired?

Rov and gps2 wired into fxti box which has wiring modifications - 2 inputs-from the previous gps explorer kit we used. We now have the latest gps2 and the plug in integration kit. The previous gps worked fine with Qgc, Gps2 not so well.

I’m not sure if Companion will be able to find the GPS at
Can it be setup for the regular

To make sure that this is the issue, open a terminal and check the output of screen -r wldriver.

Wireless the GPS2 is found at
And it’s also at on the network.

It looks like it is not finding the underwater GPS in the network.
Try running ping to be sure.

Sorry, I meant from the companion. Try that at

It is possible that your topside has connection to the Underwater GPS but the companion does not.

The older GPS explorer kit works fine, I then swap the connection for GPS2 input - that loses position. Both GPS setup at the same time and with stable positions.

Back again with a new UGPS2 and homeplug integration card. I’ve also replaced the fathom x card in the FXTI box in case that was at fault.

Still the same problem - no integration on QGC through the FXTI box. I can ping WL on (wireless) and from the control PC. The network adaptor is fixed for the FXTI/ROV USB. If I change that to I lose the ROV.

I can’t ping from the PI in the BlueROV2, and get nothing from screen -r wldriver

Ardusub is scanning for waterlinked - i’ve restarted wl driver - no change, still scanning but not finding.

Its quite frustrating - QGC works fine with the WL explorer kit but wont integrate with the WL GP2 system.

Can you open a terminal in companion and ping

We eventually got to the bottom of this Willian, the integration kit doesn’t work. We’ve used the ethernet cable and bridged the networks for now. Waterlinked are looking into a fix.

Cool! thank you for the update!