Home        Store        Docs        Blog

First time setup issues and questions

#1

I’m working on firing up the system for the first time and plugged in the USB cable and the board inside is definitely not rigid mounted. Does the board inside the Topside Interface have some float, by design?

0 Likes

(Richard) #2

If you’re meaning the Fathom X, topside interface then apparently yes this seems to be normal, I had the same concerns during my build but was reassured having spoken with the engineer at our suppliers👍

0 Likes

#3

Thanks Richard. I didn’t want to go pulling things apart, because my luck says it’d be a, “you’re never supposed to pull that side off!” kind of thing.

Changed the thread title because more things are popping up as I go along.

Had some trouble getting QGroundContol working. It wouldn’t open, so I did some reading and found others with the same issue needing to uninstall this or that. It ended up being the Intel video driver, so I uninstalled it and am just going with whatever Windows(7) is defaulting to.

When configuring motor directions, there’s tremendous lag from when I move the slider to when the thruster spins, like fifteen seconds or more. Also, video shows for a second, then turns gray for a second, then comes back for a second. Any ideas what’s going on there? I’ve rebooted the laptop and the system via the webpage, as well as unplug the battery, but no change.

Tinkering around some more, I see QGroundControl is using 88-96% CPU and 1.05G memory, so I’m guessing that’s where the lag is coming from. I’ve already uninstalled/reinstalled it a few times, so I think there’s still some software conflict going on.

0 Likes

(TCIII) #4

@corndog,

What is the speed of your topside laptop?

The minimum processor is an I5 or equivalent.

I also recommend a video display of 1080p resolution for the best performance.

My older laptop with an AMD processor would constantly display the video for a second and then cause it to turn gray. You can change the video frame size to 720p using the video tab in the system webpage ( 192.168.2.2:2770/system).

Moving up to an I7 laptop with a 1080p display resolved all of my problems.

Regards,
TCIII AVD

0 Likes

#5

The laptop is on old i5 4-core 2.4ghz Thinkpad with 8gb ram, solid state drive and 1280x800 display. It’s definitely not fast in the cpu department, but it’s very lean with only a half dozen small programs installed. Regardless, I moved over to my desktop which is an HP workstation with a couple 4-core Xeon processors, 12gb ram, solid state drive and 1920x1080 display and it’s only using around 15% cpu and it’s still doing the video thing, though sometimes it works perfectly fine. Could be a resource issue on the laptop, but I still think something is funky with a software conflict. On the desktop, I highly doubt it’s a resource issue and still think there’s a software conflict somewhere. I’ve reinstalled QGroundControl a few times and still everytime I close the program a little window pops up about the program not being installed correctly. Windows 7 on both the laptop and desktop.

Video flickering aside, the thruster lag is gone on the desktop, but a new issue has popped up, which is that thruster 7 and 8 aren’t working with “thruster test command failed”. Will need to doublecheck connections next…

0 Likes

(TCIII) #6

@corndog,

I believe that BR has stated that this version QGC works best on Windows 10, but I could be wrong.

I am running Windows 10 on everything but my antiquated workshop PC which is running Windows 7 which seems very slow compared to Windows 10.

I assume that you are using the BR version of QGC and not the stock version of QGC?

Regards,
TCIII AVD

0 Likes

#7

Correct, BR version of QGC linked through the BR Software Setup page.

You’re right about the operating system, says Win10 or later in the BROV2 store page. I missed that note in previous readings.

Looks like I’m just going to have to upgrade something. The laptop is old and the screen is small, so I think I’ll pick up a new/er Win10 laptop this week. Found some good deals on eBay from a seller about 30mi away, so I think I’ll go that route.

I visually checked thruster 7 and 8 connections they look good. Red to red, black to black, blue/green/white to blue/green/white and signal connections are all black on top, white on bottom. I can’t quite see exactly which signal connects where, but they’re all plugged into 1 thru 8, so I figure they should all at least work. 1 thru 6 are correct through the QGC thruster test page, so worst case would be that 7 and 8 are backwards. This doesn’t seem like a Win7 problem, but I suppose I’ll just have to wait a few days to know.

Thanks for the replies, TC. :slight_smile:

0 Likes

(TCIII) #8

@corndog,

Np, glad to help.

Since you mentioned thrusters 7 and 8, I assume that you have built a BR2 Heavy Lift ROV or equivalent?

I built a BR2 Heavy Lift ROV for a Marine Biologist friend and it worked the first time that it was turned on.

I assume that you setup and tested the ROV configuration as the eight thruster Heavy Lift Configuration as described here in the Software Setup Section?

Regards,
TCIII AVD

0 Likes

#9

Yes all new BR2 build with Heavy option. I did go through it and it shows the correct configuration, but the software was also acting especially screwy at that time with Microsoft Anna in an endless loop of babbling. I might try it again, but kind of feeling like I should wait until I can run through setup on Win10.

0 Likes

#10

I installed Win10 on an Asus G75VW-NS71 and went through the Heavy software update again and I had the github error 99 thing, then I found this thread:

But it crashed QGC a few times, then eventually worked, so I can now control all eight thruster manually via QGC.

Everything seems to be going pretty well, except there’s no video at all. It just shows the earth view, but in murder red. The back of the laptop has also started buzzing(not at first) when I plug in the Topside Interface, then I found this:

https://www.ardusub.com/troubleshooting/troubleshooting.html#no-video

Tether interface power supply - If you are using a tether interface board, make sure it has a solid power supply. Some laptop USB ports cannot provide enough power for the tether interface board to perform optimally. Try using a portable USB battery charger.

Anyone have similar troubles?

0 Likes

(TCIII) #11

@corndog,

Both of my laptops can power the Topside Interface Board (Fathom X) without any trouble, however I have opted to power my Topside Interface Board with a Fat Shark Li-Ion Cell Headset Battery Case. The two Li-Ion 18650 batteries can be used for several dives before needing to be recharged. There is an onboard battery indicator to conveniently indicate when recharging is required.

If you do use this setup, make sure that you purchase quality Japanese 18650 Li-Ion batteries as the South Korean versions are junk.

Regards,
TCIII AVD

0 Likes

#12

Interesting. I guess you’d cut into the USB cable and run the power wires into that doohickey and the data wires to your laptop?

0 Likes

#13

Well I installed QGC on the first laptop and it won’t even startup. Fell in love with the vehicle while building it, but the software side has been pretty awful. I think I’ve now spent more time trying to set it up than it took to assemble. Almost feeling like buying another laptop isn’t a good idea, because I don’t want to be stuck with yet another computer that QGC doesn’t work with. I wonder if I can bring the entire system in with me to Best Buy and just keep running through installation whatever computers they have until I find one that’s compatible…

0 Likes

(Kevin) #14

Hi @corndog,

Our apologies we haven’t replied sooner, many of our staff have been traveling this past weekend.

Windows 7: Windows 7 has never been a supported OS and many of the issues you have are what we saw back in 2016 when the BlueROV2 was first released. With Microsoft ending support for Windows 7 in 2020, we decided to not spend time trying to get it to work, which is why on the BlueROV2 product page, we have stated the following:

  • A laptop or a Windows 10 tablet with 8GB of RAM or higher. The topside control software, QGroundControl, works on Mac, Windows 10 (i5 processor), and Linux.

Can you list the issues you are currently having and that are unresolved and we can try to work through them one by one?

0 Likes

(TCIII) #15

@corndog,

I have the bare Topside Fathom X module mounted in a Sparkfun Red Box and have a female power connector that mates with the Fat Shark battery module male connector. The Fathom X module end of the female power connector connects to the external power supply connection on the Fathom X module.

Regards,
TCIII AVD

0 Likes

(TCIII) #16

@corndog,

I am presently using a HP Envision I7 laptop with a 1080p disaply (like this one) and it runs the BR version of QGC without a hitch. I bought my laptop at Sam’s Club for a very reasonable price last Fall.

Regards,
TCIII AVD

0 Likes

#17

No problem, Kevin! I’m just working through some things here, many of them self inflicted, but to summarize, I had been having video flickering problems with the computers that were running Win7, we’ll call them Laptop1 and Desktop1, then I installed Win10 on Laptop2 because it’s pretty solid in the specs department, but on that one there was no video at all, just the satellite image in red, though everything else seemed to be working fine. Something is also buzzing when I plug in the USB cable from the Topside Interface into Laptop2, so I’m thinking it’s unable to handle the current demand. Next I went back to Laptop1 to install Win10, but I suspected that QGC was having issues with the Intel video driver when it was running Win7, so I don’t know why I thought it would suddenly work with what is probably the exact same driver. On Laptop1, QGC won’t start if the video driver is installed, regardless of the OS.

I don’t quite feel like I’ve given this a fair shake just yet using older computers, so let me pick up a new laptop and go from there.

0 Likes

#18

That looks like a pretty solid laptop for the price, though that specific one isn’t 1080. Seems like you have to get to at least $800 before they check all the boxes; 1080, SSD, i5, 8GB, 15", etc. Something like this:

https://www.bestbuy.com/site/dell-inspiron-2-in-1-15-6-touch-screen-laptop-intel-core-i5-8gb-memory-256gb-solid-state-drive-silver/6295913.p?skuId=6295913

0 Likes

(TCIII) #19

@corndog,

If you don’t need a touch screen, put the money you will save into an I7 as you won’t regret it.

I paid $650 at Sam’s Club for my HP l7 laptop with a 1080p display last Fall.

Regards,
TCIII AVD

0 Likes

#20

Definitely don’t have much interest in a touchscreen, but it seems like that’s the direction many are going these days and it filters out too many options to specifically remove it.

I’d jump at the deal you found, but can’t seem to find anything like that around here. My closest Sam’s Club is in Roseville, CA, about an hour away. Looks like they only have two in stock…

Not terribly exciting, but they’d both probably work just fine. I’d also have to join. We’re Costco members and they have this model:

Couple reviews saying it’s slow, but I’m sure a decent solid state drive would clear that up. Of course then you’re really at $850-$900 and the slippery slope continues.

I hate computer shopping. This is why I always end up on eBay getting something a little older for 1/3 the price.

1 Like