Home        Store        Docs        Blog

Fathom X wireless topside

(Kevin) #21

Ok got, it, reconfigured the WiFi interface to a static IP of and that allowed me to sign back in. I put in the address reservations for the Pi and my computer respectively, did a restart of the system, but still no connection to QGC. Anything I’m missing?

(Jacob) #22

You can’t assign the surface computer the same ip address as the router!

The computer needs to be, the router needs to be 192.168.2.<anything other than 1 or 2>

(Jacob) #23

I’ll rewrite setup this evening, I haven’t actually hooked it up to pi/qgc since last year.

(Kevin) #24

Thanks, this networking stuff is a bit difficult for me to wrap my head around.

Here’s what I thought I had:

  1. Personal Computer: Static IP set to Also set to this in the Address reservation with the MAC from the WiFi card.
  2. RPi3: IP address deleted from from /boot/cmdline.txt. (maybe this should be added back in?) Address reservation set to with MAC for Pi.
  3. Router: Static IP set to

(Jacob) #25

That sounds right. I’ll do a beginning to end setup tonight.

(Jacob) #26

Here you go @kevink: https://www.ardusub.com/miscellaneous/wireless-topside.html

It is a bit crazy, you have to log into the router on 3 different IPs throughout the process.

(Kevin) #27

Thanks @jwalser I got my wireless fixed, good instructions!

The key for me was that I had to remove the static IP ( from my wired Ethernet interface, change that over to DHCP, and then set a static IP in my WiFi interface (

(Jacob) #28

Ok, it works, great! but… As far as I know you should not need to set a static ip on the wifi interface (I didn’t).

(Antoine Laminette) #29

Hey Jacob and Kevin,

Thank you guys, I successfully setup the same wifi connection reading your comments.

I was just wondering one last thing. What sort of range and latency do you guys have? Any constructive feedback is welcome!


(Kevin) #30

Hi @Antoine,

Great, glad it works for you! I haven’t tested the range, but it probably won’t be super fantastic, maybe 300ft at best? I was going to try something like a Ubiquiti Bullet sometime down the line: https://www.ubnt.com/airmax/bulletm/

The latency with a 1080p camera also isn’t so great. It works fine with telemetry and control, but chokes a bit on the video. I was going to try the ELP 720p camera mentioned in the components section of ArduSub and see if that reduces the latency: https://www.ardusub.com/hardware/components.html#rov-components

(Drew Fulton) #31

I’ve spent a chunk of the afternoon working on this and having some mixed results. I’m currently using a Tp-Link Archer C2 router. I chose this so I could add a big external antenna.

Anyway, I removed the static IP for the RPi and have gone through the various setups listed in the GitHub Book. So this doesn’t have the various modes to select so I went straight to setting the static ip to I reserved the MAC/IP addresses for the pi and the topside computer. Reboot and connect to Wifi. Launch QGC and I get video but it won’t connect to the ROV. I plug in the Ethernet cable to the topside computer and QGC connects to the ROV but no video. Connect to WiFi and Ethernet and I get both data and Video. I’m very confused!

update: so I’ve done a little bit of exploring. The raspberry pi is not showing up on the list of dhcp devices in the router admin. When I connect to the network on my iPad and check the devices with the Fing app, it shows the raspberry pi with the IP as I’m guessing that’s my problem. If I connect my computer over Wi-Fi and Ethernet it shows up the network list twice too.


(Drew Fulton) #32

A total system reboot seems to have fixed it all. I’m now wireless!

(Tim) #33

Please keep us updated, it would be great if you get it working smoothly. I’ve been wondering whether 802.11ac might be the solution for the latency issues.