FathomX tether consistently achieving below 30Mbits/s with all video streams disabled entirely

We’re trying to connect two @DeepWaterExploration cameras to the BR2 Pi.

The FathomX tether is consistently achieving below 30Mbits/s with all video streams disabled entirely. (approx 15-20 MBits/s with the HD stream enabled).

Some fault finding done to date:
Tried changing out the twisted pairs for all 4 sets of twisted in the tether
Tried spooling the spool while testing to eliminate the slip ring
Connected directly to the FathomX board via ethernet (no change)
Connected directly to Raspberry Pi Ethernet, achieved 100MBit.

What connection speeds should we be seeing through the 300m of tether?

Many thanks!

image

Hi @GavXYZ,

Sorry to hear you’re having trouble with your network speeds.

The network test threshold values in BlueOS are based on the 300m Standard Tether length we use for testing our ROVs in manufacturing.

I asked internally and it’s been suggested that you can try connecting the onboard Fathom-X to the topside Fathom-X via a pair of wires (i.e. bypass just the tether), which will help determine if it’s the tether that’s at fault, or one or both of your Fathom-X boards. You can also try measuring the resistance of each tether wire, and comparing it with the expected resistance values in the Fathom ROV Tether technical details. Feel free to post those results as a follow-up.

From there I’d recommend you contact support@bluerobotics.com, and provide a link to this post, together with your order number (/ rough order date) if possible. For our error tracking it would also be helpful if you can provide the BlueOS version you’re using, and whether you’re using a Raspberry Pi 3B or 4B.

Given you’ve tried all 4 sets of pairs with similar results, and a direct ethernet connection from the topside to the onboard Raspberry Pi did not display the same issues, I expect that the tether and/or Fathom-X board(s) need replacing. Assuming the equipment hasn’t been misused/damaged (e.g. cut tether causing corrosion) or extensively used we should be able to sort out a replacement or refund as appropriate :slight_smile:

Hi Eliot,
Thanks for the quick response, I’m working with Gav on this issue.

I’ve just tested the system without the tether as suggested - connecting the Fathom x boards together directly with wire, and achieved 70MBits down, and 90MBits up, which seems good.

I’ve checked the resistance, and am getting between 41.8 and 45 ohms on each cable, do you know if that is indicative of an issue?

I’m expecting 0.127 ohms per m, so 0.127*(300+8) = 39.1 ohms.

Brown 44.5
BrWh 44.3

Blue 41.8
BlWh 42.8

Green 43.2
GrWh 43.3

Orange 44
OrWh 45.2

FYI we’ve used this tether very lightly, only 3-4 dives and never had any issues. We have only noticed the bandwidth limitation now that we’re trying to add the 2x additional HD cameras.

Let me know if there’s any other testing you recommend.

Thanks again for the support, also for this forum, as a resource it is incredibly helpful.

Regards,
Kieron

Hi @XYZEng, welcome to the forum :slight_smile:

Yeah, that seems reasonable, so it’s likely not an issue with the Fathom-X boards. That leaves the tether, slip ring, and binder connectors as potential causes, but they’re all passive components, so if they’re making proper connections then I don’t know what could be wrong beyond the impedance (resistance + capacitance and inductance) being higher than expected and reducing the usable bandwidth.

I don’t know whether we’ve done detailed testing on the correlation between tether resistance and signal bandwidth. If the resistance is very high then that can understandably be a sign of corrosion or some other breakage, but when it’s still relatively close to the expected value I’m not sure whether that’s the direct cause of your lower than expected bandwidth, or if there are other causes with a larger influence.

You can try measuring the resistances for just the tether + its connector (by disconnecting it from the spool slip ring), and also measuring network speed by connecting the tether directly to the topside FXTI instead of via the slip ring, which could narrow down whether it is definitely a tether issue, or if the slip ring, top length of tether, and connectors could be at fault.

If you have the tools for it you could also measure inductance of each wire, and potentially capacitance between wires in a pair and between different pairs, but we don’t have reference values for that in the technical details so it likely wouldn’t help to identify what’s wrong without us measuring similar values for a range of tethers, and those values may also depend on how wound up the tether is, and whether it’s in air, water, or salt water.

Fair enough. We have only recently added the indicating thresholds for network performance to BlueOS, and since previously most users haven’t been trying to use additional high-bandwidth sensors (and on our longest tether length) it’s possible cases like this have gone unnoticed because performance has been good enough for ‘normal’ vehicle usage.

The tether itself does not currently have an official minimum bandwidth specification (the product page only specifies “300m is the maximum communications length for the Standard ROV Tether”), so it’s unclear to me whether this will be treated as either

  1. your vehicle works as intended, and the network test is simply informing you that your remaining bandwidth is low, so you’ll need to either work within those constraints (possibly using lower bitrates / frame rates and resolutions if you want to add extra cameras, for example) or modify/replace components to improve the bandwidth (e.g. shorten your tether, get a different tether, get a fibre-optic tether setup, etc), or
  2. we test our vehicles to have at least 30 Mbps download and 40 Mbps upload speed with a 300m tether, and your setup is not providing that, so we should replace the components that are performing below our minimum speed levels

That decision is out of my hands, so I’d recommend you email support to continue the discussion about whether a replacement is appropriate, and if so what kind.

Thank you for the comprehensive response Eliot.

1 Like

I may be mistaken, but I thought there was some discussions quite a while ago regarding the difference in tether performance when spooled, and un-spooled. Something to do with it being unshielded twisted pairs?

@k-deboer from a quick search, you’re probably thinking of this post, but that discussion effectively says “we tested network performance with different tether lengths, and ended up with our current ratings for reliability reasons”. Both the spooled state and the possibility of shielding are mentioned, but not discussed in depth.

Not blind tested, but using 300 m BR tether, it has helped us bandwithwise to spread the tehter on the deck instead of having it coiled. Result have been going from ~20Mbit to ~40Mbit after uncoiling.
This has been in enviroments with hydraulic pumps, generators etc making magnetic fields.

1 Like

I sometimes notice significant speed differences between different deck leads (the ~15 foot cable that runs between the cable reel and FXTI box). If you have more than one around you might try swapping them or at least re-seating its connections.

1 Like

i will add that sometimes the reason for low network performance is the result of power limiting done by the computer, and also not having the newest drivers availabel.

1 Like