Fathom-X Tether Interface - Link Slow

Hi,
I’m trying to get the Fathom-X tether interface working, and have gotten a link, but the bandwidth is very low, usually around 20 mbps down and 2 mbps up. Unfortunately, this is not enough for my purposes, so am looking for help fixing it. My boards are directly connected with 2ft of CAT5 cable (1 pair) and have 12V power supplies.

I’ve integrated the design for the Fathom-X onto a custom PCB (RPi CM4 carrier) that will go on the ROV, but neither using that version nor an original Fathom-X board yields high enough speeds connected to a Fathom-X on the surface.

My ethernet connection is 300/300 into the surface-side Fathom-X, tested with both the custom PCB and my laptop.

I’ve seen the post about the potentially incorrect diode, but both of my boards’ diodes are marked 5C, and I’ve tested with 2 different pairs of Fathom-X, just to be sure. None worked.

Any help would be appreciated
Thanks

Hi @snadol -
I would suggest testing with a longer cable! The FathomX is designed for a single twisted pair, usually tens of meters long. Is your application going to only use 2’ or is that just what you’re testing with?
Best of luck!

Thanks, I’ve also tried it with a longer length (~15 ft) of 4 pair BlueRobotics tether - same speed. My final application will use about 20m of the same, but I don’t have that ready to use yet, so I can’t test with it unfortunately.

Would the 15ft be enough to achieve the expected speeds or do I need a longer cable still? Thank you!

Hi @snadol -
Are the wires you’re using with the FathomX a twisted pair?
And to confirm, you’re seeing low speeds with no custom PCB on either side of your connection?
What voltage are you supplying to the units?

The wires are one twisted pair of a Fathom tether, each connected to one end of a Fathom-X board. Each Fathom-X has a 12V 2A wall power supply.

I should have more time to test tomorrow to see if I can eliminate any more variables.

Thanks!

Best of luck @snadol !
If you continue to have issues, please reach out to support@bluerobotics.com so we can discuss returning the hardware for evaluation and getting you a replacement. Thanks!

Hi,
Sorry for the late reply, I did some more testing and still no luck. I get ~25 (20-30)/2 to WAN with speedtest-cli and 50/8 on LAN with iperf. I’ve replaced every component in the system (including Fathom-X boards, I have 2 pairs) and am now at a loss.

One thing I noticed was that I got the same speeds with either 1 or 2 wires connected on either end - does that have any implications on what might be wrong?

Thanks

Sorry to revive an old issue, but I did some more testing and have figured something out. With the same setup, I can still only get 20/2 speeds on the initial powerup, but if I keep both boards powered up and swap the polarity of the tether on only one end, the speeds can get up to 40/50, which is enough for my use case. Have you ever seen this issue before? Any way I can get it to just do that at the start?

Thanks

EDIT: On further investigation, it’s not just if I swap the wires, but any time I break the link long enough for the ‘link’ light on the board that’s not being touched to turn off. As I do this, it appears that the speed is alternating between 20/2 and 40/50 each time the link is broken. If I unplug the board on the surface and plug it back in before the link light on the other turns off, the same speed remains, but if I wait for the light to turn off, the speed changes. Very odd behavior.